How to connect my jitsimeet server to my openfire xmpp server

I am totally new to jitsimeet. I have an openfire xmpp server running at openfire.hetnet.org. I want my jitsimeet installation at jitsi.hetnet.org to use that openifre server instead of prosody. How do I configure that? Do I need to configure Jicofo?

I now have videobridge sip-communicator properties like so:

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=openfire.hetnet.org
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=openfire.hetnet.org
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=m4JlEab2
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@jitsi.hetnet.org
org.jitsi.videobridge.xmpp.user.shard.MUC=JvbBrewery@jitsi.hetnet.org
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=45a37f80-c50b-45de-adc8-541ec964d0d7

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@openfire.hetnet.org/.*

This is the videobridge config file:
'# Jitsi Videobridge settings

'# sets the XMPP domain (default: none)
JVB_HOSTNAME=openfire.hetnet.org

'# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)
JVB_HOST=openfire.hetnet.org

'# sets the port of the XMPP server (default: 5275)
JVB_PORT=5275

'# sets the shared secret used to authenticate to the XMPP server
JVB_SECRET=Lktnv2Sn

'# extra options to pass to the JVB daemon
JVB_OPTS="–apis=,"

'# adds java system props that are passed to jvb (default are for home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

This is my jicofo sip-communicator.properties:
org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.jitsi.hetnet.org
org.jitsi.jicofo.auth.URL=XMPP:jitsi.hetnet.org
org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true

This is my jicofo config:
'# Jitsi Conference Focus settings
'# sets the host name of the XMPP server
JICOFO_HOST=openfire.hetnet.org

'# sets the XMPP domain (default: none)
JICOFO_HOSTNAME=openfire.hetnet.org

'# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=Lktnv2Sn

'# sets the port to use for the XMPP component connection
JICOFO_PORT=5275

'# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN=openfire.hetnet.org

'# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus

'# sets the password to use for XMPP user logins
JICOFO_AUTH_PASSWORD=Lktnv2Sn

'# extra options to pass to the jicofo daemon
JICOFO_OPTS=""

'# adds java system props that are passed to jicofo (default are for home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

What is the org.jitsi.videobridge.xmpp.user.shard.HOSTNAME for? And org.jitsi.videobridge.xmpp.user.shard.DOMAIN?

Hello,
How did you get on with this? Did you enable the external component in Openfire?
https://desktop.jitsi.org/Projects/JitsiVideobridgeWithOpenfire