How to config transcrption?

Hello,
I’m trying to use transcription, and I installed jitsi-meet, google-cloud-SDK, jigasi.

When I run APP.conference._room.dial(“jitsi_meet_transcribe”) in chrome, I can see the transcriber join the meeting then disconnected. and a message(Transcriber is not properly configured. Contact the service administrators and let them know! I will now leave.) can you help me to check it.

And below is the installing info of google cloud sdk. should I do anything else for it?

Summary

root@jitsi-test:/home/firstuser# gcloud init
Welcome! This command will take you through the configuration of gcloud.

Your current configuration has been set to: [default]

You can skip diagnostics next time by using the following flag:
gcloud init --skip-diagnostics

Network diagnostic detects and fixes local network connection issues.
Checking network connection…done.
Reachability Check passed.
Network diagnostic passed (1/1 checks passed).

You must log in to continue. Would you like to log in (Y/n)? y

Go to the following link in your browser:

https://accounts.google.com/o/oauth2/auth?redirect_uri=urn%3Aietf%3Awg%3Aoauth%3A2.0%3Aoob&prompt=select_account&response_type=code&client_id=32555940559.apps.googleusercontent.com&scope=https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcloud-platform+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fappengine.admin+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcompute+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Faccounts.reauth&access_type=offline

Enter verification code: 4XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXAXXXXX
You are logged in as: [michael01chaochao@gmail.com].

Pick cloud project to use:
[1] e-centaur-232307
[2] vibrant-chain-234506
[3] Create a new project
Please enter numeric choice or text value (must exactly match list
item): 2

Your current project has been set to: [vibrant-chain-234506].

Not setting default zone/region (this feature makes it easier to use
[gcloud compute] by setting an appropriate default value for the
–zone and --region flag).
See https://cloud.google.com/compute/docs/gcloud-compute section on how to set
default compute region and zone manually. If you would like [gcloud init] to be
able to do this for you the next time you run it, make sure the
Compute Engine API is enabled for your project on the
https://console.developers.google.com/apis page.

Created a default .boto configuration file at [/root/.boto]. See this file and
[https://cloud.google.com/storage/docs/gsutil/commands/config] for more
information about configuring Google Cloud Storage.
Your Google Cloud SDK is configured and ready to use!

  • Commands that require authentication will use michael01chaochao@gmail.com by default
  • Commands will reference project vibrant-chain-234506 by default
    Run gcloud help config to learn how to change individual settings

This gcloud configuration is called [default]. You can create additional configurations if you work with multiple accounts and/or projects.
Run gcloud topic configurations to learn more.

Some things to try next:

Enter verification code: 4XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Credentials saved to file: [/root/.config/gcloud/application_default_credentials.json]

These credentials will be used by any library that requests
Application Default Credentials.

To generate an access token for other uses, run:
gcloud auth application-default print-access-token
root@jitsi-test:/home/firstuser#

jicofo.log (30.0 KB)
jigasi.log (55.0 KB)
jvb.log (153.0 KB)

Apparently jigasi is not finding the environment variable.

2019-03-25 20:19:39.815 WARNING: [123] org.jitsi.jigasi.transcription.GoogleCloudTranscriptionService.log() Google Credentials are not properly set
java.io.IOException: The Application Default Credentials are not available. They are available if running in Google Compute Engine. Otherwise, the environment variable GOOGLE_APPLICATION_CREDENTIALS must be defined pointing to a file defining the credentials. See https://developers.google.com/accounts/docs/application-default-credentials for more information.

What is your jigasi version?
Where did you add the variable?

Hi,Damencho
Thank you for your quickly reply.

My jigasi version is 1.0-217

I config /etc/jitsi/jigasi/config add
export GOOGLE_APPLICATION_CREDENTIALS=/root/.config/gcloud/application_default_credentials.json

Is this credentials like this?
vim /root/.config/gcloud/application_default_credentials.json
{
“client_id”: “764086051850-6qr4pXXXXXpt8ejuXXXX1hur.apps.googleusercontent.com”,
“client_secret”: “d-FL95Q1XXXXXXXXpd7hHD0Ty”,
“refresh_token”: “1/H8cj_vxNXXXXXXXXXRe8K6xCACJKpcb5pGna2c”,
“type”: “authorized_user”
}

This is the systemd enabled jigasi. Remove the export word from /etc/jitsi/jigasi/config
Leave it as just GOOGLE_APPLICATION_CREDENTIALS= and try again.
Also this file “/root/.config/” cannot be read by jigasi user. Make sure jigasi user can read the file.

Hi

How to find the credentials after running the Google cloud SDK. Do i need to login to Google Cloud ? if yes, where can i find it.
Any other settings are required in Google cloud .

you can see the credentials path when you finished running
gcloud init
gcloud auth application-default login

you will be asked to login to Google Cloud with browser to get the verification code

Hi,Damencho
It works now, Thank you.

I can acitve transcription form web-console or invite-button. I can see words received in Chat box.
But when I click CC button, nothing happened, so how to actived this?

Thanks Michaelchen

I have configured the google and its working fine.

Just wanted to check if you are able to change the transcript file name format to Date-Start Time-Meeting ID.
The transcripts are getting saved to /var/lib/jigasi/transcripts but it too long.

I am also checking how to use IBM or Sphinx instead of Google.

Prem

When you click cc button you should activate the transcriptions … and see transcriptions as subtitles.

You are receiving transcriptions in the chat? This is an old jigasi. Are you using stable? I will update jigasi in stable in few hours and then you need to just update it.

I am receiving the Transcrptions in the chat now. I am also checking how to show the transcription only for the Moderator.

Thanks I will update Jigasi.

You can update now from stable I just updated it.
There is no option for only moderator to see the transcriptions.

Thanks I followed this step

apt-get update
apt-get install jigasi
Should i update the sip-communicator.properties or can i keep the old one?

Prem

Please do not cross-post every time.

Sorry about it.

I have updated the new jigasi. but it is still can not activate transcriptions.

I still use invite(jitsi_meet_transcribe) , and if I checked cc, I can see subtitles.
and unchecked cc with no subtitles .

my jitsi-meet version is 1.0.3548-1, I used the quick install guide of jitsi_meet.

anything else need to be updated?

Subtitles are the transcriptions, what do you mean you cannot activate transcriptions? What do you want to activate?

My purpose is when I click cc button, it will auto invite (jitsi_meet_transcribe) and show me the subtitles.

But now I click cc button, nothing happened. I must input (jitsi_meet_transcribe) with click “+” button.

This is how it is supposed to work. Testing it here works that way. When you click cc button do you see after a while TR indication in the upper right corner? If you see it, transcriber is in.

I can’t see TR indication in the upper right corner after click cc button. And no logs in Chrome console.

I only can active transcribe with “+” button , it’s very strange.