How to config OCTO

From the screenshots you posted, the last line of your sip-communicator.properties reads “vorg.jitsi…” instad of “org.jitsi…”. Since this is the line that configures the region, it would cause the failures you describe. Without more details, this is my only guess.

Boris

Hi @Boris_Grozev.
Thank for answer .I edited it but OCTO not active.
You can give me the detail way to config OCTO?

Hi @damencho.
You can help me check all my config,maybe i can something miss?

Server 1, I installed full.
config_jvb2.txt (837 Bytes)
sip-communicator.properties_jvb2.txt (878 Bytes)

config_jicofo.txt (1011 Bytes)
config_jvb.txt (836 Bytes)
prosody.cfg.lua.txt (8.3 KB)
sip-communicator.properties_jicofo.txt (197 Bytes)
sip-communicator.properties_jvb.txt (871 Bytes)
vcrxdev9.topica.vn.cfg.lua.txt (1.7 KB)
vcrxdev9.topica.vn-config.txt (14.0 KB)

Server 2, I only installed jvb and jitsi-meet.
config_jvb2.txt (837 Bytes)
sip-communicator.properties_jvb2.txt (878 Bytes)
vcrxdev10.topica.vn-config.txt (14.0 KB)

I need when I visit conference vcrxdev9.topica.vn/123 I will using jvb(region161) on server 1 ,vcrxdev10.topica.vn/123 using jvb(region185) on server 2.

Thanks for alot.

Hi Bùi Xuân,

Your jitsi-meet installation on the dev10 server seems broken. I’m not sure why. Have you modified index.html?

Note that the config files you posted contain some credentials and IP addresses.

Regards,

Boris

Hi @Boris_Grozev, thanks for answering.
sorry, I did edit it. Now you can check again for help me.
Thank.

Hi,

The clients are configured correctly now (they have the two different regions in deploymentInfo and they enable octo), but jicofo doesn’t use the second bridge.

I don’t see anything obviously wrong in the config. You should look in the jicofo logs next. It could be that:

  1. The second bridge fails to connect to the XMPP server (because of e.g. a network problem)

  2. The bridge connects, but jicofo doesn’t know about it (you have the statistics ‘transport’ properties commented out, and I’m not sure how jicofo will behave)

  3. Jicofo knows about the two bridges, but chooses to not enable octo.

Regards,

Boris

Hi @Boris_Grozev.
Here are my jicofo.log ang jvb.log. Can you check and give me some detail advise.

jicofo.log.txt (23.0 KB)

jvb.log https://drive.google.com/drive/u/0/folders/1X4JWLAKYnJvjhBpHG98Cg_QlMTBETbT4

Thanks

I checked list jvb connect then it has two jvb connected
http://42.112.28.161:8888/about/health?list_jvb=true

Oh, here’s the problem: jicofo doesn’t know the bridges’ regions! You need to enable the stats (for example with pubsub) for that to work.

Boris

Hi @Boris_Grozev.
I don’t know how to enable the stats. Can you give me example, thank you?

@Boris_Grozev thanks for alot. it worked to me

Hi @Boris_Grozev.

I have a question. On mobile app have use config coto?.

Thanks.

Hi @Boris_Grozev.
I installed 1 JVB on AWS. but when enter conference with this JVB then it can’t share connected to and other
image

JVB AWS on using ip 172.31.18.*
You can check it on 2 my system https://vcrxdev9.topica.vn/thuanbx and https://vcrxdev10.topica.vn/thuanbx

Thank a lot.

请问你的问题解决了吗?

Hi Bui Xuain,

Did you resolve the problem?
I’m kind of stuck in the same situation, could you help me out with the config files?
Thanks in advance.

Can you please help me to fix this issue. Need to test that whether it's working or not after enabling OCTO . Thank you.

@akalana which version are you using?

@Bui_Xuan_Thu_n . Thank you very much for your reply. This issue is fixed. Need to setup Search GeoIP2

Hi @Bui_Xuan_Thu_n,

Could you please help to setup octo to multiple video bridges, I have single jitsi meet server in that jicofo and prosody running and have 3 video bridge servers (jvb). the current environment working fine. when we are creating multiple rooms with less members (20). But I am looking for single room can take 75 to 90 users and that room can use all my video bridge servers (jvb). For that we need to configure octo right.
I need your help how to configure octo in my current environment, is it octo installed or enabled default.

bheema