How to change certificate after default Meet installation

Hi All,
I have set up a Ubuntu 20.04 server with a default Meet install; Jetty Web server ( I believe) and self signed certificate. Meet working but browsers are generating security warning because of self sign cert. I followed steps to generate a letsencrypt wildcard SSL using certbot (with autorenew) and that appears to have worked as I can see the cert files in /ect/letsencrypt (although they are all .pem which I have not used before). However I am entirely stumped at how to apply this new cert to Meet. If you can assist please can you address your response to a linux newbie - I am from the MS world and have only a basic familiarity with Linux configuration.
Thanks
Kip

Did u solve it? i have the same issue

No…

Copy your crt + key to your server…
first you combine your onw crt + ca bundle to one file…

cat yourssl.crt yourssl.ca-bundle > yoursite-bundle.crt

Check the result, make sure no overlapping between end and start of certificate… all certificate should be like this

-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----

then edit nginx site config for your domain…

nano /etc/nginx/sites-available/your.domain.conf

replace these path to your own key and yoursite-bundle.crt

ssl_certificate /etc/letsencrypt/live/vc.inti.co.id/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/vc.inti.co.id/privkey.pem;

For example it would be like this if you put your key and ssl bunlde at /etc/myssl:

ssl_certificate /etc/myssl/yoursite-bundle.crt;
ssl_certificate_key /etc/myssl/yoursite.key;

Finnaly we do a reload on nginx

systemctl reload nginx

viola… its already move from letsencrypt to new ssl…

I had the same issue and it fixed by reinstall jitsy and choose my own certificate option.

When I only made Change on nano /etc/nginx/sites-available/your.domain.conf it shows that my web has self-signed certificate and the lock icon was showing my certificate details.

I hope this help you