How to call a http jicofo rest api from my https domain?

I am calling a POST api to jicofo endpoint.
url: http://xxx.xx.xx.xxx:8888/sendChat
and in Jicofo resr services I’ve added this API handler, it is working when I am testing out in Postman. But when inside the jitsi client end I am requesting this url, Browser is not allowing as http is requested from https.

Mixed Content: The page at ‘https://xxxxxx’ was loaded over HTTPS, but requested an insecure resource ‘http://xxx.xx.xx.xxx:8888/sendChat’. This request has been blocked; the content must be served over HTTPS.

So how can I bypass this block without changing browser settings? Or how can I add a https Jicofo rest API endpoint?

Making requests over HTTP is generally frowned upon due to the security implications. Since you need to be on an HTTPS site for using WebRTC you could proxy the requests in your server, so they arrive via HTTPS to your nginx and then they go via HTTP to jicofo.

ok, I am not sure how will I do that though.
can I request jicofo with https endpoint? I mean jicofo https port can be exposed?

Look at how your webserver is configured for the http-bind endpoint. It uses this proxy technique I mentioned, You’lll want to do the same.

ok, let me check

Thank you, worked as you said.