How to avoid 8X8 commercial?

I use the external Jitsi API (‘https://meet.jit.si/external_api.js’) to allow the participants of an online conference to communicate in pairs. This works fine the first time. However, when I reenter this feature, I see an add from 8x8 and need to scroll down for the video communication. This is very confusing for new users of the tool. Is there anything I can do to avoid this? I tried randomizing the roomName and the userInfo.displayName, but that did not help.
I use the following call (in javascript):

var api;
const domain = ‘meet.jit.si’;
let options = {
roomName: response.url,
width: ‘100%’,
height: ‘100%’,
userInfo: {
displayName: mycomm.myname + “_” + myRand,
},
parentNode: document.querySelector(’#videoParentNode’)
};
api = new JitsiMeetExternalAPI(domain, options);

Best
Gunther Maier

You could try SHOW_POWERED_BY: false, and SHOW_PROMOTIONAL_CLOSE_PAGE: false,

Thank you for your reply. However, it does not work. Since I could not find these options in the Jitsi Meet API documentation at https://github.com/jitsi/jitsi-meet/blob/master/doc/api.md, I used the following:

let options = {
roomName: response.url,
width: ‘100%’,
height: ‘100%’,
userInfo: {
displayName: mycomm.myname + “_” + myRand,
},
SHOW_POWERED_BY: false,
SHOW_PROMOTIONAL_CLOSE_PAGE: false,
parentNode: document.querySelector(’#videoParentNode’)
};

That did not work.

try adding this code, should work

        configOverwrite:{

        },
        interfaceConfigOverwrite:{
            DEFAULT_BACKGROUND: "#3b98ff",
            SHOW_JITSI_WATERMARK: false,
            noSsl: true,
            JITSI_WATERMARK_LINK: '#',
            SHOW_BRAND_WATERMARK: false,
            SHOW_WATERMARK_FOR_GUESTS: false,
            SHOW_POWERED_BY: false,
            TOOLBAR_BUTTONS: [
                'microphone', 'camera', 'closedcaptions', 'desktop', 'fullscreen',
                'fodeviceselection', 'hangup', 'profile', 'recording',
                'livestreaming', 'etherpad', 'sharedvideo', 'settings', 'raisehand',
                'videoquality', 'filmstrip', 'feedback', 'stats', 'shortcuts',
                'tileview'
            ],
        }
    }
    var api = new JitsiMeetExternalAPI(domain, options);
    api.executeCommands({
        toggleShareScreen: [],
        toggleVideo: [],
        toggleAudio: []
    });
   });
</script>

Thank you for your code. It is helpful, but does not solve the problem. I checked the content of the page and found out that the server iframes with ids “jitsiConferenceFrame0”, “jitsiConferenceFrame1” and so on, where only the last one is the video frame. All the others are 8x8 commercial frames.
I have “solved” the problem by looping through ids 0 to 9, setting all that exist to “hide” and then setting the one with the highest number to “show”. It is a wild hack. So, I still hope for a more direct solution.