How to adjust "Reconnecting in..." time?

I’ve got self-hosted setup.
Everything is under my control :wink: I’ve restarted video bridge service, and got the following screen:


It’s expected, it’s OK.
The question is: may I reduce this reconnecting timeout?
I want to try to reconnect in, say, 5 sec. (not 30!)

You’d need to modify the code and rebuild the frontend, there is no config for it IIRC.

Thanks @saghul, I’ve just wanted to write an answer by myself :smile:


Actually, we may change it without recompile.
Yes, there’s no configuration setting for this, but a little JS-code exploring gives an answer.
The file where this “setting” lives is: jitsi-meet/AbstractPageReloadOverlay.js at master · jitsi/jitsi-meet · GitHub
(or better with line number - jitsi-meet/AbstractPageReloadOverlay.js at master · jitsi/jitsi-meet · GitHub)
Here it is:

const timeoutSeconds = 10 + randomInt(0, 20);

How to adjust the setting:

  1. In the installed product the compiled file we need is:
    /usr/share/jitsi-meet/libs/app.bundle.min.js

  2. In this file search for (0,20) string. There should be something like const t=10+kK(0,20);

  3. Edit this file and replace this to, say: const t=5; for 5-seconds reconnect.

  4. Overwrite old /usr/share/jitsi-meet/libs/app.bundle.min.js with your changed version.

  5. IMPORTANT! Clean cache of the client’s (and server’s if you use web version) browsers, because this file is being cached.

  6. Reload service, restart browsers. etc.

  7. Profit! :grinning: