How to add tenant/group in JitsiConnection/JitsiConference via jitsi-lib-meet

Hey there,

thanks for your work on jitsi!

We setup Jitsi with JWT authentication and have our own frontend based on lib-jitsi-meet. But sadly we do not know how to tell the conference the tenant name. If we add the tenant name at the beginning of the room name, like “tenant/roomname” it does not work. So where should we add it?

The JWT authentication does work via the jitsi meet frontend if we call it with “domain.xx/tentant/roomname?jwt=$token” and in the logs we see that the room is only “roomname” without the tenant.

Can someone help us and tell me where we should put the tenant in the lib-jitsi-meet conference?

In your hosts section instead of having conference.domain.tld you must have conference.tenant.domain.tld.

1 Like

Tank you for your response.

I’m a colleague of @derTobsch. We just applied your suggestion and it works!

What we did in detail:
When we create the JitsiConnection, in the options we pass conference.tenant.domain.tld for hosts.muc. Then any room we join with this connection will be within the group tenant.

2 Likes

Thanks @saghul, all information we gathered over the last days are now in this PR to improve the documentation Improve 'JSON Web Token (JWT) authentication Prosody plugin' documentation by derTobsch · Pull Request #2049 · jitsi/lib-jitsi-meet · GitHub