How to add sip gateway in jitsi meet?

What changes should be done in jitsi meet config file,jigasi’s file and in prosody for adding sip gateway in my jitsi meet application?I did some changes but I am little bit confused in configuring jitsi meets’s configuration file.Also toolbar appears after adding some sip properties in configuration file of jitsi meet.Could you please help me for solving this issue?

I’m guessing you are talking about outfoing calls?
Have you followed this?
Do you see jigasi connecting by examining its logs?
So you see in jicofo logs that it detects that instance of jigasi?

I am getting this UI after doing proper configuration in jigasi and my sip server.
But when I add some sip properties and authentication properties in jitsi-meet config file,jitsi-meet UI shows Rejoin again button and it showing continuously …
Could you please tell me where I am going wrong ? If possible please provide me some documentation or reference.
Because of too many config file changes, I think, I am little bit confused.

when doing changes in config file of jitsii meet ,I got logs as shows in provided screenshot.

Getting this UI after above changes in jitsi meet config files host section.

Check js console logs in the browser about the error you see there, what is it?
Your jigasi is not authenticating so I guess it is bot connecting the brewery room.
The config.js and the part after authdomain, is wrong not sure where you took it from, also authdomain why you need to set that?

Could you please tell some suggestions about authenticating jigasi and configuring config file of jitsi meet?
As I have set all the parameters in file.And I am not getting any error while checking running status of all jigasi,kamailio,prosody and videobrodge.

Clear jigasi log, restart jigasi and uploud the log file here.


Please when uploading logs or stuff use something like github gist and paste links, screenshots are hard to read.

So jigasi joined call control room, when this happens you should be able to see in jicofo logs that it had detected it, do you see it? What is the error in the web console?

==> jicofo.log <==
Jicofo 2023-04-19 03:25:51.972 INFO: [87] AutoOwnerRoleManager.electNewOwner#105: Electing new owner: ChatMember[id=0711b7d0 role=PARTICIPANT]
Jicofo 2023-04-19 03:26:55.739 INFO: [87] [ meeting_id=8c047521-e5fd-4ddc-b865-f67547d9aeb3] JitsiMeetConferenceImpl.onMemberLeft#830: Member left:0711b7d0
Jicofo 2023-04-19 03:26:55.740 WARNING: [87] [ meeting_id=8c047521-e5fd-4ddc-b865-f67547d9aeb3] JitsiMeetConferenceImpl.onMemberLeft#845: Participant not found for 0711b7d0. Terminated already or never started?
Jicofo 2023-04-19 03:26:55.743 INFO: [87] [ meeting_id=8c047521-e5fd-4ddc-b865-f67547d9aeb3] JitsiMeetConferenceImpl.stop#423: Stopped.
Jicofo 2023-04-19 03:26:57.482 INFO: [90] ConferenceIqHandler.handleConferenceIq#75: Focus request for room:
Jicofo 2023-04-19 03:26:57.483 SEVERE: [90] ConferenceIqHandler.handleConferenceIq#92: No XmppConnectionConfig for vnode=null
Jicofo 2023-04-19 03:26:57.484 INFO: [90] [] JitsiMeetConferenceImpl.#264: Created new conference.
Jicofo 2023-04-19 03:26:57.484 INFO: [90] [] JitsiMeetConferenceImpl.joinTheRoom#446: Joining
Jicofo 2023-04-19 03:26:57.765 INFO: [82] [ meeting_id=c2ff2f2d-8274-43a2-bb3a-1b35aa4b32bd] JitsiMeetConferenceImpl.onMemberJoined#632: Member joined:0de06b24 stats-id=Taurean-0lk region=null audioMuted=true videoMuted=true role=PARTICIPANT isJibri=false isJigasi=false
Jicofo 2023-04-19 03:26:57.765 INFO: [82] AutoOwnerRoleManager.electNewOwner#105: Electing new owner: ChatMember[id=0de06b24 role=PARTICIPANT]

==> jigasi.log <==
2023-04-19 03:21:46.251 SEVERE: [4388] CallControlMucActivator$DialIqHandler.processIQInternal#634: [ctx=16818744961251788387691] Error processing RayoIq
java.lang.Exception: Fail to join muc!
at org.jitsi.jigasi.xmpp.CallControlMucActivator$WaitToJoinRoom.waitToJoinRoom(
at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.setDialResponseAndRegisterHangUpHandler(
at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.processIQInternal(
at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.lambda$processIQ$0(
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/
2023-04-19 03:22:06.281 WARNING: [12] XMPPBOSHConnection[not-authenticated] (1) was not authenticated

I guess without having your prosody config, that you have enabled authentication, but you haven’t created jigasi user as the normal users.
And you need to configure this: jigasi/ at b5002fc8a98eba39b8590b82b0fc827a21bd104e · jitsi/jigasi · GitHub
In case of authentication jigasi needs 2 accounts, one user account this above. And one for the call controll room that jicofo is using to discover dial out jigasis.

ok ,I will try.
Thank you for your gentle help @damencho