How I disable websockets in newer (latest) Docker / Jitsi versions?

Hi,

I have the opposite problem from the one that appears more often: For quite some time, I have been running and upgrading a docker-based jitsi installation. When I first installed it (didn’t care about the release then), websocket wasn’t a standard, obviously, so it ran without it just fine.

Now, I set up a new server with the latest release, clean install. Websocket (both JVB and XMPP) working fine, but I found out that some client’s corporate network firewall doesn’t let websocket communication though. Effectively, the entire company is shut out. Tweaking the firewall won’t work.

I guess I could always trace back releases until I reach one that doesn’t have websocket as a standard, but that’s very very counterproductive. Questions about the most recent release:

  • Is it possible to disable websockets entirely?
  • If it is, how? I’m finding the JVB (colibri-ws) websocket particularly confusing, because I can’t compare it to my old configuration due to a new “jvb.conf” file in the new releases
    • XMPP seems to be easy enough: ENABLE_XMPP_WEBSOCKET=0
    • I tried the following for JVB, but got odd websocket-related errors in he browser’s console
      ENABLE_BRIDGE_CHANNEL=1
      BRIDGE_CHANNEL=datachannel
  • General question: Does it make sense at all, or will the RTC support in jitsi be dropped in the near future anyway?

Maybe someone closer to the development can answer these basic question straight away, before I go deeper into any debugging - which might be a lost race right from the start, if non-websocket communication will (or is already) deprecated.

Any help appreciated!

Thanks!

  1. No, It is not possible to remove websockets if using latest images.
  2. you can disable websocket for prosody but not for JVB.
  3. yes, Jitsi team is dropping RTC support.

AFAIK you have to enable SCTP in jvb as welll as in jicofo but there’s no way you can enable it in jicofo using sip-communicator.properties file. This functionality is available in jicofo.conf file(new kotlin config). There are couple of PR’s in jitsi docker repo. Below are the links. try ENABLE_SCTP=true and also disable websockets for jvb in web/meet.conf file.


Great answer, I’ll try that asap! Guess I missed the jicofo config!

And for the whole situation, it’ll buy the client some time to fix his firewall, and I won’t have to resort to outdated releases.

Thanks!

Hi,

didn’t work. Guess that the new jicofo config isn’t in production yet, regarding the current docker images?
I’ll wait a bit until the dust of recent changes has settled before I try again.

Cheers!

to use this new config you have to build you own docker image.

Hi, I have the same Problem as @Alfred_Grimpelhuber Alfred.
Since my Company is currently setting up a Jitsi Environment (yes we’re a bit late on that train), and one of the biggest reasons for us is WebRTC Support, I’m kind of worried, since I read here that the Team will drop WebRTC support.
@metadata Do you, or in fact someone else have like a Statement from the devs that they’ll drop that?

And anyway, is there a solution to the Problem?
@Alfred_Grimpelhuber, did you find a solution?

I’m not aware as of now but looping in @Freddie @saghul for more information.

Drop webRTC support? Maybe I’m misunderstanding something in this question, but I don’t see how dropping webRTC support could be remotely true; Jitsi is based on webRTC.

1 Like

@MK4zy Can you please share the source of this news?

I got that from you…
Could be, that I simply understood you wrong.

Whaaaaatttt? :cold_face:

No Issues. As mentioned by @Freddie It’s not gonna happen(as of now but no one knows the future) so you can go ahead with your installation. :+1:

Updating my Answer since all three points I mentioned earlier is not correct.

Yes, it is possible to switch to SCTP(no-WebSocket).

Yes, In the latest docker images, you can disable WebSocket for both prosody and jvb.

Actually I was talking about SCTP not WebRTC. @MK4zy I’m really sorry for this.

oh, thats good news :smiley:

But I still have the same Problem as the original Autor of this thread/post.

To specify it a bit more:
I installed jitsi in a testing environment in the Azure cloud.
Later, when the system is used productively, we’ll install it on one of our servers internally.

But currently neither Video or Audio is working fluently when one joines from inside the company network. Outside works flawless.
Now to change our firewall in that regard is literally the last option, if my boss doesnt decide that we’ll look for another solution besides jitsi in that case.

In the Console it logs something of the following:
Snippet of Log

I’m running the Docker Version with the Images Version 5765-1

You got that wrong. You probably misunderstood it with dropping WebRTC datachannels. At any rate, that’s not happening either. :slight_smile:

Your bridge channel is not working properly. Check your web server configuration in case you are using a reverse proxy.