How do yo UPGRADE working Jitsi-Meet + Jibri etc to latest stable or Git master version?

I have jitsi-meet installed and working fine but it was installed with apt-get install on Ubuntu 17.04 and seems like its pretty old compared to latest release or git version. Can someone point me to docs on what’s best way to UPGRADE installation to latest release or Git master from source?
thanks!