How do I record a jitsi meeting locally?


I am new to using Jitsi Meet and want to record a meeting and store it on my computer. Is this possible? How? I tried the recording function but that only seemed to give the option to share my screen? I saw someone on YouTube recommended using RecordRTC, but that doesn’t seem to be broadly used. What is a safe way to record a meeting?


Welcome to the forum!

Are you using your own installation of Jitsi or the public instance at If using the public instance, your recordings are indeed local (local Recording) with the file being saved to your downloads folder on your computer.

Hi Freddie, thanks for your help!

I don’t have anything installed. Someone else created the link for the meeting, so I think that means it’s a public instance of

I checked my download folder but there is nothing there unfortunately. Do you have any advice on what I could try?

Thanks again for your help. It’s much appreciated!

Not necessarily. You should be able to tell from the link - it will show the URL of the server. On, your recordings are stored locally (you can try it yourself). If it’s a private server though, they may not have the feature enabled or may be doing serverside recording instead (which is only available to the meeting host).

Thanks again for helping me. The URL just says{name of the meeting}{some numbers}

Where would I be able to find the recording? Should I enter the meeting again?

Sorry I am really new to working with Jitsi and I don’t really understand half of what’s going on. I really appreciate your help!

Ah, it’s on then, so that’s good.

When you’re in a meeting, click on the ellipsis in the toolbar (shown below) and select ‘Start recording’ from the pop-up menu list.

Then make sure the option to “Save recording file locally (Beta)” is selected (it’s selected by default).

Screen Shot 2023-01-09 at 10.19.43 AM

Make sure you end the recording before exiting the meeting (otherwise, the recorded file will be lost). The file will then be saved to your designated downloads folder on your system.

Thank you so much! Your help is really appreciated a lot :slight_smile:

I think that’s what wrong then: I ended the meeting before stopping the recording, but now I will at least know what to do next time. Thank you and have a great day!

This may sound a stupid question but how you stop the recording? If I go to More actions → Stop recording I get the confirmation dialog
However I do not get any recording in my downloads folder. What am I doing wrong?

Did you click “Confirm”? And after that, you don’t get the recorded file in your downloads folder?
Maybe check to confirm your setting has “Downloads” as the default directory for downloaded files.
Also, what browser are you using?

Yes, I clicked and I did not get a recorded file. However your question about what browser I use, made me test on another one. So the conclusion seems to be that recording does not work on Opera on MS Windows 10 Enterprise N 64-bit (both updated to the latest).