How do I make sure participants enter without a password?

I’ve install jitsi meet my own server (ubuntu 20) than i’ve activated JWT token. I can create room with JWT token. But when i share my room link with participants, they cant join and password screen opens.
How do I make sure participants enter without a password?

Do you share the room link which contains a token?
If yes, probably there is something wrong with the token’s content

When i login first time, i use JWT token link and it was successfull. When inviting guests, there are no token in the url. So guest participants cant join.

create a link with a token for each participant or set allow_empty_token to enable the guests to join

Is this scenario possible?

  1. Only administrators open sessions with JWT and start the session.
  2. When a link is shared with guests, it should enter without a password.

This scenario is possible. Check these two Prosody modules

I tried this solution but failed.
I am logging in as a host, but when the participant tries to log in without jwt token, the password prompt screen appears.

VirtualHost "your.domain.com"
authentication = "token"
...
...
allow_empty_token = true

Don’t forget to restart the prosody service

Thank you very much for your help, it worked :slight_smile:

1 Like