How customize jitsi meet welcome page with authentication

Hev you modified the logging configuration? Check syslog, logs may have gone there.

This is my syslog file

Where i find logging config file
what i need to change in logging configuration

Is jicofo actually running? Check with systemctl status jicofo and check the output with journalctl -xe

systemctl status jicofo

output with `journalctl -xe

Hi saghul

My Conference page neither connecting nor show error. please help me to find solution
Screenshot attached

Have you been able to check prosody logs, bosh returning 504 maybe an error in prosody.

How to check prosody logs

/var/log/prosody.log IIRC

This is output prosody.log

Feb 14 06:25:03 general info Re-opening log files
Feb 14 06:47:19 mod_bosh info New BOSH session, assigned it sid ‘485552a9-85f6-421f-bcdd-93ab1454123e’
Feb 14 06:47:19 bosh485552a9-85f6-421f-bcdd-93ab1454123e info BOSH client disconnected
Feb 14 06:47:31 mod_bosh info New BOSH session, assigned it sid ‘056ecf5b-9732-403e-8936-3eaf31a485aa’
Feb 14 06:47:31 bosh056ecf5b-9732-403e-8936-3eaf31a485aa warn No available SASL mechanisms, verify that the configured authentication module is working
Feb 14 07:04:12 bosh056ecf5b-9732-403e-8936-3eaf31a485aa info BOSH client disconnected
Feb 14 07:12:22 mod_bosh info New BOSH session, assigned it sid ‘5cb8ecfa-f48f-466d-be05-0172a608f887’
Feb 14 07:12:22 bosh5cb8ecfa-f48f-466d-be05-0172a608f887 info BOSH client disconnected
Feb 14 07:12:31 mod_bosh info New BOSH session, assigned it sid ‘b4c68875-5170-4595-af51-f305e1e39bed’
Feb 14 07:12:31 boshb4c68875-5170-4595-af51-f305e1e39bed warn No available SASL mechanisms, verify that the configured authentication module is working
Feb 14 07:21:58 boshb4c68875-5170-4595-af51-f305e1e39bed info BOSH client disconnected
Feb 14 07:22:00 mod_bosh info New BOSH session, assigned it sid ‘9527545f-700b-4f8a-a80c-7bff46ced9ab’
Feb 14 07:22:00 bosh9527545f-700b-4f8a-a80c-7bff46ced9ab info BOSH client disconnected
Feb 14 07:22:13 mod_bosh info New BOSH session, assigned it sid ‘6ce8ad96-b35a-4d32-ab6e-0061eb6d7219’
Feb 14 07:22:13 bosh6ce8ad96-b35a-4d32-ab6e-0061eb6d7219 info BOSH client disconnected
Feb 14 07:35:00 mod_bosh info New BOSH session, assigned it sid ‘93511aea-c430-4875-b943-3d313f65dcff’
Feb 14 07:35:00 bosh93511aea-c430-4875-b943-3d313f65dcff info BOSH client disconnected
Feb 14 07:53:29 mod_bosh info New BOSH session, assigned it sid ‘bda68cbb-c9ab-48d3-a92d-f171fddaafd8’
Feb 14 07:53:29 boshbda68cbb-c9ab-48d3-a92d-f171fddaafd8 info BOSH client disconnected

This is suspicious, is there anything in /var/log/prosody.error?

there is noting in prosody.error
black file

Hi damencho

Right now i am able to use authentication with username and password
Can you please tell me, Can i use multiple user authentication in sip-communicator.properties file

What do you mean?
You can create as many users as you wish in prosody.

Thanks for reply
How to create number of user in prosody can you share any reference


There is a section how to create user

Hi damencho

Can i limit participant for each conference
I mean if i have create a xyz room and i want to only 5 user join this room
i have another room abc and only 3 user join this room
How to do this

There is just one setting per all rooms https://github.com/jitsi/jitsi-meet/blob/master/resources/prosody-plugins/mod_muc_max_occupants.lua

Hi damencho
it is possible if moderator login first in room other user do not need to login they only join conference
if it is possible which file i need to modify and how to do this

Follow these instructions https://github.com/jitsi/jicofo/blob/master/README.md#secure-domain

Jicofo requires special ‘owner’ permissions in XMPP Multi User Chat to manage user roles. Because of that it needs adminsitrator credentials to start. By default Jitsi Meet uses XMPP domain with anonymous login method(jitsi.example.com), so additional VirtualHost has to be added to Prosody configuration(etc\prosody\prosody.cfg.lua):

You mean to say we have to edit the file etc\prosody\prosody.cfg.lua?