How can I configure to authenticate room IDs

my setup is like this:

My Django App (Q&A) ------> Jitsi Server (Video Conferencing)

I create room ID in my django app and redirect the both users to the new meet URL with room ID.

what I want to achieve is to disable room creating from browser.

how can I do it? I am new to jitsi and all the terminologies are kind of confusing to me

take a look at the JWT

if I use JWT, jitsi does not ask for username and password, right?
I dont need authentication in browser, only in background to make sure room is valid to use. if not authenticated, I want to redirect user back to Q&A page (django app)

yes

yes

AFAIK need a little customization

1 Like

great, thanks man. I will test and paste the config here for others as well

I can not get it working. I see no video and no audio, browser logs says:

Strophe: Server did not yet offer a supported authentication mechanism

what am I doing wrong?

I already set consider_bosh_secure=true in main prosody settings. I have also set

org.jitsi.jicofo.auth.URL=EXT_JWT:mydomain.com

@damencho could you please help? :confused:

Remove the jicofo config, but that is not your problem. Check prosody logs for errors

it says:

error Error initializing module ‘auth_token’ on ‘mydomain’: /usr/lib/prosody/util/startup.lua:199: module ‘luajwtjitsi’ not found:No LuaRocks module found for luajwtjitsi

I followed this setup: https://doganbros.com/index.php/jitsi/jitsi-installation-with-jwt-support-on-ubuntu-18-04-tls-2/

it seems to be same issue as here: Prosody can't find luajwtjitsi 5.2 module

okay I installed git, and installed luajwtjitsi again. now everything works. Thanks for this awesome software @damencho!