How can I cancel the random room creation?

Hello

When I log in as meet.domain.com, it automatically creates a room name, how can I turn it off? I researched before posting here.

It says “GENERATE_ROOMNAMES_ON_WELCOME_PAGE: false” in /usr/share/jitsi-meet/interface_config.js is enough, but it doesn’t work…

Do I need to do anything else?

Thanks.

Do a test meeting in incognito (private mode in browser).

I tried 3 different computers in incognito mode but the result is still the same :frowning:

Can you share your interface_config.js?

Do you have welcome page disabled in config.js by any chance?

    // Whether to use a welcome page or not. In case it's false a random room
    // will be joined when no room is specified.
    enableWelcomePage: true,
1 Like

Hi there

Yes, registered as " enableWelcomePage: false, "

Hello

https://justpaste.it/8lwaw

Thank you

That’s the problem. Disabling the Welcome page overrides GENERATE_ROOMNAMES_ON_WELCOME_PAGE. You could perhaps redirect to another static page if you don’t want the Welcome page to show up.

1 Like

Hi there

How can I do the redirect?

Also, thank you very much for your urgent help.

You can use Nginx. Probably create a location block at the root in the https section to redirect to the static page. That’s not really a Jitsi-specific thing so you can google how to, if you’re not sure.