"host not found in upstream xmpp.meet.jitsi"

I ran docker-compose up; and it worked so that I could video conference with my friend far away (with some port forwarding). Now I’m trying to add these four jitsi services to a docker stack I have already running. I copied the definitions from the docker-compose.yml in the repo (https://github.com/jitsi/docker-jitsi-meet/blob/stable-5142/docker-compose.yml), and copied any environment variables that were set in my .env to the swarm’s docker-compose file.

When it runs, the “web” service repeats the following every second or so:

nginx: [emerg] host not found in upstream “xmpp.meet.jitsi” in /config/nginx/meet.conf:48

line 48 is at the bottom of meet.conf in <config>/web/nginx/meet.conf (as expected I guess) in the # BOSH section. That section reads:

# BOSH
location = /http-bind {
proxy_pass http://xmpp.meet.jitsi:5280/http-bind;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_set_header Host meet.jitsi;
}

This was generated automatically when I ran the service after deleting all the configuration files; I haven’t adjusted it.

Apparently there’s supposed to be a xmpp.meet.jitsi machine around here somewhere? Also apparently this worked fine when I ran docker-compose up earlier. In short, how do I begin diagnosing the problem?

I may have solved the problem checking out this guy’s configuration: [Docker-Swarm][Traefik]Guest Authentication isn't working with docker swarm and Traefik. He used meet.example.in which made me think that perhaps I should be using my proper domain name. I changed all the meet.jitsi to my real domain name and now the web service starts without error. I’m not able to test yet because I’m still configuring the DNS situation, but I’ll be sure to post back.