Host jitsi from my existing website

https___meet_themysteriesoftherosary_net

Looks like SSI is not working?

1 Like

I need the .htaccess in a parent directory of all source containing includes. I made sure that there were no include errors showing in the logs. So where is this code so I can put an .htaccess file in the directory?

/usr/share/jitsi-meet

I opened and saved it again and this time it expands the includes. Now I get
Logger.js:154 2021-06-09T22:24:40.340Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: Uncaught ReferenceError: config is not defined Script: https://meet.themysteriesoftherosary.net/libs/app.bundle.min.js?v=4985 Line: 1 Column: 55245 StackTrace: ReferenceError: config is not defined

You can look directly at the html via
https://meet.themysteriesoftherosary.net/

config is also ssi from index.html
and it is an alias jitsi-meet/jitsi-meet.example-apache at a3a9eab57a480fc857f0c0837ef26637f06a55d9 · jitsi/jitsi-meet · GitHub

I think we got it! Mostly you guys! Thank you so very much! Your patience is exemplary. I will begin testing audio visual etc. now. I am so excited!

1 Like

Ok, I started a meeting “GregsFirstMeeting” on my pc. Then I went to my iPad and put it on a different network and went to the site via browser and entered “GregsFirstMeeeting” then I went to my phone and did the same again using the browser.
each seemed to create a new instance of a conference rather than joining to the first one. I could see an audio level indicator when I talked but no audio went anywhere.

Try two: I installed the jitsi on both my android phone and my ipad. I went to settings and set up a unique name for each device and entered the url of the server. The I entered a room name;“Greg2” neither the phone or the ipad connected the loading indicator just kept spinning.

So any idea what I did wrong?

I looked at the apache2 log and found:
AH01368 missing directive name in parsed document /user/share/Jitsi-meet/index.HTML, referrer: https://meet.themysteriesoftherosary.net/GregsFirstMeeting

Occurring many times with and without the room name.

Honestly, I wouldn’t put an existing Website AND Jitsi on the same Server. Even if it might work now, painful debugging in any updating process is pre-programmed, combined with a potential downtime of your Website.
I recommend setting up a second Server, set an A-Record for a subdomain, and you’re done! :slight_smile:

I found this in the jicofo.log:

org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from conference.meet.themysteriesoftherosary.net: XMPPError: remote-server-not-found - cancel.

And this is in the jvb.log:

JVB 2021-06-08 20:50:41.967 WARNING: [19] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$8#591: [MucClient id=shard hostname=localhost] error connecting
org.jivesoftware.smack.XMPPException$StreamErrorException: host-unknown You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorThis server does not serve auth.meet.themysteriesoftherosary.net</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1059)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.lang.Thread.run(Thread.java:748)
JVB 2021-06-08 20:50:41.968 WARNING: [26] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[not-authenticated] (0) closed with error
org.jivesoftware.smack.XMPPException$StreamErrorException: host-unknown You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorThis server does not serve auth.meet.themysteriesoftherosary.net</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1064)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.lang.Thread.run(Thread.java:748)
JVB 2021-06-08 20:50:41.968 WARNING: [26] [hostname=localhost id=shard] MucClient$1.connectionClosedOnError#277: Closed on error:
org.jivesoftware.smack.XMPPException$StreamErrorException: host-unknown You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorThis server does not serve auth.meet.themysteriesoftherosary.net</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1064)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.lang.Thread.run(Thread.java:748)

These would seem to be related configuration errors but I don’t know where to look.

Any help would be appreciated. I am getting very close to have a function system.

You probably need to add “reboot your server” to the install instructions. That is all it took to fix the issues once it was installed. Thank all of you very very much for your assistance and patience. It is nice to be up and running.