Higher Audio for dance lessons

Hello,

I have a question and hope someone can help. First I have to mention I have a self-hosted jitsi on a root server. The version i have installed via jitsi sources has the new version of config files. So many hints are not working on my installation. Please remember.

First of all the jitsi is working fine also for meetings over hours with 6 or 7 paticipant. But i wanna use jitsi for dance lessons and the sound is quite poor and often interrupted.

The interruption I think I can eleminate when I mute all other. Or is there a more intelligent or automatic way?

But what can i do for quality of sound. I want to make settings fixed in system and i don’t want to have page wide urls with thousands of options. Yes exaggerate but I hope you understand. The jitsi is mainly used for music purposes so if i want normal then i can use the link options.

Stereo would be fine too.

I upload every file, log or configuration you want please tell me.

Many thanks Oerni

Welcome to the forum.

There are quite a few posts here on how to disable audio processing e.t.c… Do a search for disableAP, for instance and that should put you on track.

I have read many topics but as i Said No one Said how IT works with new config Files.

Do you try to send the music through microphone?

When sharing the music using a youtube video (from the Jitsi menu), is there quality problem?

as you were talking about dancing lesson, do you need video to be in good quality too?
if you only care about audio then you can just disableLypsync, Stereo, enableRTX, Opus bitrate to 48000 and enable opusRed too. you can enable/disable audio processing like auto gain/noise suppression etc by judging your use case & disable audio level measuring have good effect. but if you also care about video you can lower the audio bandwidth, disable stereo so that it doesn’t affect the bandwidth or video quality depending on your available bandwidth. more over, all of these are if you are not using screen share, meaning direct contact… but if you are sharing youtube video like things (screenshare) then you have to maximize the screenshare framerate and disable capScreenshareBitrate to get best output.

1 Like

you need to understand what is happening. Use the Chrome console and go to the network tab, WS sub tab to examine the Payload messages of type stat and examine the stats for the clients. If you have packet loss, you may take some actions (lowering video, raising available bandwidth, using fixed wire network instead of wifi…). If you don’t there is more investigating to do.

Hi, this is a real problem.
Jitsi is missing the basic function ‘Share computer audio’ like Zoom has, for my experience.
There are some difficulties to overcome this missing feature in Jitsi.

  1. The server must have the correct configuration. Ask the experts… Try another server…
  2. The host who wants to share audio has to do the call with the query string #disableAP=true added to the complete IP.
  3. The host must have a VB virtual audio cable installed within Windows.
  4. The sound of your audioplayer on the host has to be directed to the virtual cable. Hope it’s possible.
  5. The hosts micro input of Jitsi has to be directed to the VB virtual cable, it’s a browser feature.
  6. You have to use a Chromium derivate as browser, Firefox doesn’t work. Greetings from Google.
  7. To hear your own transmitted sound you have to use a second device as a listener. I use the DAW Cakewalk to direct my audio from VB cable back to speaker. But this is really difficult.
  8. The host has to switch from VB virtual cable to micro if he wants to use it. Then the micros own inbuild audioprocessing has to be enabled. Better use the micro of the listener.

@Developers If I’m right then my question is: Who invented this? “Sharing computer audio” is a urgently needed regular feature of Jitsi.