High CPU utilization on client end

The several spikes in your CPU usage originate from the “Recurrent neural network for audio noise reduction” audio processing filter that eliminate ringing during a multi party call.

You can experiment with disable some audio processing options in the config.js:

 // Disables all audio processing
 disableAP: true,
 
 // Disables Acoustic Echo Cancellation
 disableAEC: true,

 // Disables Automatic Gain Control
 disableAGC: true,

  // Disables Noise Suppression
 disableNS: true,

 // Disables Highpass Filter
 disableHPF: true,

Without the audio processing you will hear feedback loop noise from speakers to microphone. The feedback loop noise can be avoided if everyone are using headphones :headphones: .

Disable of all audio processing is also OK if you only have one speaker and everyone else listen with mic turned off.

3 Likes

Further i have disabled most extra indicators that cause GUI re-layouts thus reduce CPU load on the client browsers
set in the /usr/share/jitsi-meet/interface_config.js

SET_FILMSTRIP_ENABLED: false,
DISABLE_FOCUS_INDICATOR: true,
DISABLE_DOMINANT_SPEAKER_INDICATOR: true,

I have also disabled the popup messages when someone enters the room:
also set in the /usr/share/jitsi-meet/interface_config.js
DISABLE_JOIN_LEAVE_NOTIFICATIONS: true,

4 Likes

Thanks for the useful tips! Will try to find the time shortly to test the various options.

Can you explain what these 2 options do in the GUI? It’s not clear for me
Thanks :slight_smile:

SET_FILMSTRIP_ENABLED: false,

This filmstrip option makes the miniature square icons on the right side start hidden. There is a small “<” symbol on the right to un-hide the miniature square icons of all participants if you want to see them.

DISABLE_DOMINANT_SPEAKER_INDICATOR: true,
This option disable the blue megaphone button :mega: at the top left corner of the current speaker

DISABLE_FOCUS_INDICATOR: true,
This option removes the moderator mark in the thumbnail

3 Likes

I noticed that 28% of CPU was consumed by the video background for one user, thus to reduce CPU usage edit the /usr/share/jitsi-meet/interface_config.js and set
DISABLE_VIDEO_BACKGROUND: true,

2 Likes

I was able to test with the various settings. Only saw a noticeable decrease in CPU load when turning down the resolution to 240. CPU was then down from 100% to around 80% in a meeting with to participants. After number 3 joined the CPU went up to around 95%. With number 4 the audio started to run async with the video and the “can you here me? are you still there?” started.

On this particular PC, I give up.

Hello I have a 100% CPU usage on two decent PC I have at home. Jitsi is launched in Chrome by a remote school web app (https://www.weschool.com/). Everything therefore is inside Chrome and I have no idea on where to find the configuration file on the Win 10 OS folders.
Where should I look to disable the jitsi features that kill my CPUs?
Thanks

Should I use links like the one cited above?
@xranby @voxter

Yes if weschool makes links to meet.jit.si then you need to change the link like above.

Same here, the CPU utilization is massive (and I did not have this issue weeks ago) - so there must have been a change on the Mac Chrome side or the Jitsi side.

Best way to describe what is causing the high CPU load on your machine is to record it using chrome and share the stored performance profile here.

In chrome do the following:
Right click -> inspect page -> Select “Performance” tab -> un-select screenshot, select memory -> press record circle -> stop record after 10 seconds -> press the "down arrow "save profile to disk icon -> upload the Profile-*.json file here
This file can be loaded and analyzed to see what keeps your CPU busy.

1 Like

Here you go: I just had a video call with one single person, both video on, both good network reception. In gallery view.
https://www.dropbox.com/s/ywnvzc503w32gvh/JitsiProfile-20200427T124826.json.log?dl=0

P.S. By the way, the idea with #config.disableAudioLevels=true did not make any difference.

I looked at your profile.

The summary looks OK, the page is mostly idle. According to this your CPU is 89% idle.
Skärmbild från 2020-04-27 18-34-09
9% of used CPU time is spent in calculateAudoFrameVAD.
Skärmbild från 2020-04-27 18-35-38
Thus from a first glance the profile you sent do not show any massive CPU use…

However the frames looks a bit odd… it looks like some frames take half a second to render! Normal frame time is 30ms (for 30fps)… not 577ms !!! Do the image stutter?

1 Like

Yes, video was stuttering as well. And the rest of the machine could not be used practically anymore (Quad-core Macbook Pro…)

Because i could not see any CPU related issue:
Can you try disable the hardware accelerated codec:

disableH264: true,

( found at 2 locations in /etc/jitsi/meet/*-config.js )

2 Likes

I can’t edit the config.js files as I’m using meet.jit.si service

The guys from „freifunk münchen (Munich) https://meet.ffmuc.net/ did a lot of adjustments including disabling the blue speeking dots and harder downscaling. My cpu usage is slightly lower on my Mac than using meet.jit.si but still ultra high compared to Zoom or Google meet .
Nevertheless Jitsi is the number one tool for me .

1 Like

I found a workaround by disabling hardware acceleration in Google Chrome on my Mac in the Advanced Settings section. Then the massive CPU usage is no longer there and everything else works in video calls. So seems an issue with the hardware acceleration?

6 Likes