Hiding certain controls on iOS

meet
sdk
#1

I am using Jitsi Meet SDK for iOS with Rocket Chat. It is working quite well.
But I need to hide certain controls like I wanna hide chat button in Jitsi, as for chat there is Rocket Chat. Also there are options like “add” more participants in a call or “share” video conference url. So I want to hide these options in 1-1 call.

How can I hide/remove these options in UI ? I checked the SDK and didn’t find any relevant configurations. Kindly point me in the right direction.

I tried ‘iAmRecorder’ option in configurations but it isn’t do anything on iOS.

0 Likes

#2

Hi there, welcome to the Jitsi community!

There is currently no way to do this from the SDK. You’d need to edit the code and rebuild the SDK.

0 Likes

#3

Here is where you’d want to edit the code: https://github.com/jitsi/jitsi-meet/blob/30669c7699dca5e8ae1a58233d168c7d2a8021b0/react/features/toolbox/components/native/Toolbox.js#L242

and https://github.com/jitsi/jitsi-meet/blob/30669c7699dca5e8ae1a58233d168c7d2a8021b0/react/features/toolbox/components/native/OverflowMenu.js#L98

We do have plans to add this kind of customizability to the SDK, but have no ETA yet.

0 Likes

#4

Thanks for the quick reply. I really appreciate your help.

I had tried building the SDK myself from the source, following the steps mentioned here


I tried with Xcode 10.1 and 10.2, with legacy build system and new build system but no luck so far.
I am always getting this issue
“/DerivedData/jitsi-meet-dtggabnjlafzohezucwqwkwnzchu/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeet/BuildProductsPath/Release-iphoneos/JitsiMeet.framework/main.jsbundle does not exist.”

and it simply fails
PhaseScriptExecution Package\ React\ bundle /Users/user/Library/Developer/Xcode/DerivedData/jitsi-meet-dtggabnjlafzohezucwqwkwnzchu/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeet/IntermediateBuildFilesPath/sdk.build/Release-iphoneos/JitsiMeet.build/Script-0BCA49651EC4B77500B793EE.sh

not sure if I am missing anything here… if you know anything about this issue, please mention.

Thanks

0 Likes

#5

Yeah, our docs are not great, sorry about that :-/

Here is how you build the SDK: https://github.com/jitsi/jitsi-meet/blob/master/ios/README.md#builduing-it-yourself

0 Likes

#6

yes I am following this process step by step to build the SDK… but getting this error
“/DerivedData/jitsi-meet-dtggabnjlafzohezucwqwkwnzchu/Build/Intermediates.noindex/ArchiveIntermediates/JitsiMeet/BuildProductsPath/Release-iphoneos/JitsiMeet.framework/main.jsbundle does not exist.”

:confused:

0 Likes

#7

Can you paste (better use a Gist or some other pastebin-like service) a bit more of the error? Did you install all node dependencies with npm install ? What Xcode version are you using?

0 Likes

#8

I have used both Xcode 10.1 and 10.2 and I did install all the dependencies with “npm install”.
Below is the link of the gist containing complete log

https://gist.githubusercontent.com/nasirmehmood/1188471a8c91e4a3a96c82b233652e04/raw/20ac2bce75f6c2f9fa67c1939756ecf93c714982/sdk%2520build%2520error

I am not sure if it would be any help, but looking closely, at the end of the log it is showing the following error

/Users/user/Documents/NoBackup/temp/jitsi/jitsi-meet-master/node_modules/@react-native-community/cli/build/cliEntry.js:168
async function run() {
^^^^^^^^

SyntaxError: Unexpected token function
at createScript (vm.js:56:10)
at Object.runInThisContext (vm.js:97:10)
at Module._compile (module.js:549:28)
at Object.Module._extensions…js (module.js:586:10)
at Module.load (module.js:494:32)
at tryModuleLoad (module.js:453:12)
at Function.Module._load (module.js:445:3)
at Module.require (module.js:504:17)
at require (internal/module.js:20:19)
at Object. (/Users/user/Documents/NoBackup/temp/jitsi/jitsi-meet-master/node_modules/@react-native-community/cli/build/index.js:5:40)

  • [[ false != true ]]

may be this is causing the issue ?? :thinking:

0 Likes

#9

never mind, I fixed the issue… I had multiple node versions installed and Xcode was using v6.14.4 which was causing the issue as ‘async’ is not support till node v7…
I changed it to use node v8 and it is building successfully…

Thanks for the quick responses. Keep up the awesome work. :+1::+1::+1:

1 Like