Hide "Avatars" when on JitsiMeetView confrence

meet

#1

I couldn’d figure the way to hide Avatars. On screen sharing (in landscape) I need to hide avatars as cover a significant area of screen in a mobile device.

Is there something really obvious that I missed? Or if there is a solution that can be coded I will need some direction in that case. Check attached screen (sharing one) and notice the significant area covered by avatars, this is worst when we have some content that student need to learn.


#2

Are you using a modified version of jitsi-meet?
When you are screensharing this is detected and the shared area is fit outside the avatar, you can check that on meet.jit.si:


See on the screenshot the avatars are not covering anything from the screen shared area.


#3

@damencho, thank you so much for quick response. I exported iOS frame work from stable code which I pulled during January this year.

I noticed it works on web, I queried about mobile screen. Screenshot that I shared is from my iPhone 7 sharing my windows laptop screen. And as you may have noticed apart from shared screen there are 2 avatars on top right of image, I want these to be auto hidden just like other control buttons.

I checked the sdk document and function information but I couldn’t find any option in mobile SDK where it allows me to do above. If above can not be achieved then I would loke to go for reducing avatar window size by 50% when in landscape mode with screen sharing.


#4

Yeah it was not obvious from your screen share the scenario, apparently this is not available on mobile, but there you have pinch and zoom which you don’t have on desktop.


#5

Alright. :slightly_frowning_face:.

So you think I should try an edit it in React code to modify the behavior?