Help with port issue. Confused by components and ports

I have a self-hosted Jitsi Meet server on Debian Linux.

I really like Jitsi and everything was working well. However, something went wrong after I rebooted. I’m trying to diagnose the issue but this system is a bit confusing.

The web server, along with ports 80 and 443 is working.

For Jitsi, there’s jicofo (Java), jvb (Java), Prosody (Lua). Prosody is an XMPP server (right?) but then there is JVB and in that, there’s a config option for the XMPP port. Is Prosody part of JVB? I see separate processes for them.

The Prosody process seems to have four TCP ports open. There’s the jabber server, client, the BOSH/XMPP websockets and XMPP server.

Jifoco is apparently using port 8888 TCP and 5774 UDP. I don’t see where those are configured but the docs don’t list them as ports I need to forward.

Videobridge has a UDP port open but it’s not 10000. I might have changed this but I can’t find the setting anywhere. It apparently has nothing to do with the JVB port.

My log files are showing a port error for videobridge (“Failed to bind single-port”) but they don’t tell me what port.

I recently started using Docker for some things and it seems like a good system. I wonder about using it for Jitsi.

Three questions:

  1. How do I diagnose the port issue?
  2. Where is the setting for port 10000?
  3. Would it be easier to manage a docker-based install?

Thank you.

I restarted the JVB service and now it’s listening on port 10000 :thinking:
It was definitely not listening before.

How do I see where its ports are configured? It has another UDP port open.

AFAIK it starts listening after it gets the first request.

The default port is UDP/10000. If you want to change it, add the following line into /etc/jitsi/videobridge/sip-communicator.properties

org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=10002

The default comes from reference.conf

1 Like

you probably have another process listening on port 10000. Check other software installed on your server.

you probably have another process listening on port 10000. Check other software installed on your server.

No, there was nothing listening on 10000. I checked.

Thanks. I’ll look at that.

For some reason, I see it listening on udp6 and not udp. That seems like an issue.

that’s OK