Help with jibri (error: Failed to start Jibri Process.)

When doing a jibri status check, I get the following error:

 jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-11-08 21:47:33 UTC; 1min 20s ago
  Process: 1498 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
 Main PID: 1498 (code=exited, status=1/FAILURE)

Nov 08 21:47:33 jitsi.cuality-meet.com systemd[1]: jibri.service: Service hold-off time over, scheduling restart.
Nov 08 21:47:33 jitsi.cuality-meet.com systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Nov 08 21:47:33 jitsi.cuality-meet.com systemd[1]: Stopped Jibri Process.
Nov 08 21:47:33 jitsi.cuality-meet.com systemd[1]: jibri.service: Start request repeated too quickly.
Nov 08 21:47:33 jitsi.cuality-meet.com systemd[1]: jibri.service: Failed with result 'exit-code'.
Nov 08 21:47:33 jitsi.cuality-meet.com systemd[1]: Failed to start Jibri Process.

Could this error affect the jibri?

prosody.service - LSB: Prosody XMPP Server
   Loaded: loaded (/etc/init.d/prosody; generated)
   Active: active (running) since Sun 2020-11-08 21:57:05 UTC; 7min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1062 ExecStart=/etc/init.d/prosody start (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/prosody.service
           └─1198 lua5.1 /usr/bin/prosody

Nov 08 21:57:04 jitsi.cuality-meet.com systemd[1]: Starting LSB: Prosody XMPP Server...
Nov 08 21:57:04 jitsi.cuality-meet.com prosody[1062]:  * Starting Prosody XMPP Server prosody
Nov 08 21:57:05 jitsi.cuality-meet.com prosody[1062]:    ...done.
Nov 08 21:57:05 jitsi.cuality-meet.com systemd[1]: Started LSB: Prosody XMPP Server.
Nov 08 21:57:05 jitsi.cuality-meet.com prosody[1198]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281
Nov 08 21:57:05 jitsi.cuality-meet.com prosody[1198]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

check your jibri log first?

no, how can i do it?

**Nov 08 19:15:37 voffic-meet launch.sh[4850]:         at com.typesafe.config.impl.ConfigImpl.computeCachedConfig(ConfigImpl.java:93)**
**Nov 08 19:15:37 voffic-meet launch.sh[4850]:         at com.typesafe.config.ConfigFactory.load(ConfigFactory.java:258)**
**Nov 08 19:15:37 voffic-meet launch.sh[4850]:         at com.typesafe.config.ConfigFactory.load(ConfigFactory.java:234)**
**Nov 08 19:15:37 voffic-meet launch.sh[4850]:         at org.jitsi.jibri.config.Config.<clinit>(Config.kt:26)**
**Nov 08 19:15:37 voffic-meet launch.sh[4850]:         ... 2 more**
**Nov 08 19:15:37 voffic-meet systemd[1]: jibri.service: Main process exited, code=exited, status=1/FAILURE**
**Nov 08 19:15:37 voffic-meet systemd[1]: jibri.service: Failed with result 'exit-code'.**
**Nov 08 19:15:38 voffic-meet systemd[1]: jibri.service: Service hold-off time over, scheduling restart.**
**Nov 08 19:15:38 voffic-meet systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.**
**-- Subject: Automatic restarting of a unit has been scheduled**
**-- Defined-By: systemd**
**-- Support: http://www.ubuntu.com/support**
**--**
**-- Automatic restarting of the unit jibri.service has been scheduled, as the result for**
**-- the configured Restart= setting for the unit.**
**Nov 08 19:15:38 voffic-meet systemd[1]: Stopped Jibri Process.**
**-- Subject: Unit jibri.service has finished shutting down**
**-- Defined-By: systemd**
**-- Support: http://www.ubuntu.com/support**
**--**
**-- Unit jibri.service has finished shutting down.**
**Nov 08 19:15:38 voffic-meet systemd[1]: jibri.service: Start request repeated too quickly.**
**Nov 08 19:15:38 voffic-meet systemd[1]: jibri.service: Failed with result 'exit-code'.**
**Nov 08 19:15:38 voffic-meet systemd[1]: Failed to start Jibri Process.**
**-- Subject: Unit jibri.service has failed**
**-- Defined-By: systemd**
**-- Support: http://www.ubuntu.com/support**
**--**
**-- Unit jibri.service has failed.**
**--**
**-- The result is RESULT.**
**Nov 08 19:17:01 voffic-meet CRON[4906]: pam_unix(cron:session): session opened for user root by (uid=0)**
**Nov 08 19:17:01 voffic-meet CRON[4911]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)**
**Nov 08 19:17:01 voffic-meet CRON[4906]: pam_unix(cron:session): session closed for user root**

cat /var/log/jitsi/jibri/log.0.txt

1 Like

2020-11-08 19:32:03.170 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [--config, /etc/jitsi/jibri/config.json]

is it running with config.json? I thought it was running with the jibri.conf … am I wrong?

its from config.json in my jibri…

I understand, then configure the config.json and leave the jibri.conf empty?

yup now jibri use config.jsos…

check this out https://github.com/jitsi/jibri/pull/324

@alveox no, that’s untrue. Actually, the latest version of Jibri uses Jibri.conf. However, config.json is still supported for the time being as well; with time, it will be completely deprecated, so the advise is to start using Jibri.conf.

@Camilo_Pimentel did you register the necessary usernames and their corresponding passwords in prosody? Did you confirm that the names and usernames match the values you populated your jibri.conf with?

Did you add jibri to all the necessary groups?

usermod -aG adm,audio,video,plugdev jibri

@Freddie Yes sir, I share my jibri.conf, the users and the results:

#cat /etc/group | grep jibri

adm:x:4:syslog,jibri
audio:x:29:jibri
video:x:44:jibri
plugdev:x:46:jibri
jitsi:x:1000:jibri
jibri:x:997:jibri

Jibri.conf:

jibri {
 
  id = ""
  single-use-mode = false

  recording {
    recordings-directory = "/srv/recordings"
    finalize-script = "/usr/local/bin/finalize_recording.sh"
  }
  streaming {
    rtmp-allow-list = [
      ".*"
    ]
  }
  chrome {
    flags = [
      "--use-fake-ui-for-media-stream",
      "--start-maximized",
      "--kiosk",
      "--enabled",
      "--disable-infobars",
      "--autoplay-policy=no-user-gesture-required"
    ]
  }

  api {
    http {
      external-api-port = 2222
      internal-api-port = 3333
    }
    xmpp {
      
      environments = [
                {
                    name = "mydomain enviroment"
                    xmpp-server-hosts = ["mydomain.com"]
                    xmpp-domain = "mydomain.com"

                    control-muc {
                        domain = "internal.auth.mydomain.com"
                        room-name = "JibriBrewery"
                        nickname = "jibri-nickname"
                    }
                    control-login {
                        domain = "auth.mydomain.com"
                        username = "jibri"
                        password = "jibriauthpass"
                    }
                    
                    call-login {
                        domain = "recorder.mydomain.com"
                        username = "recorder"
                        password = "jibrirecorderpass"
                    }
                    
                    strip-from-room-domain = "conference.mydomain.com"
                    
                    
                    usage-timeout = 1 hour
                    
                    /
                    trust-all-xmpp-certs = true
                }
      ]
    }
  }
  
  stats {
    enable-stats-d = true
  }

  call-status-checks {
    no-media-timeout = 30 seconds
    all-muted-timeout = 10 minutes
    default-call-empty-timeout = 30 seconds
  }
}

the users prosody that were created:

prosodyctl register jibri auth.mydomain.com jibriauthpass
prosodyctl register recorder recorder.mydomain.com jibrirecorderpass

I appreciate all help:) … a happy day

strip-from-room-domain is wrong. Check this

@emrah I still have the same problem, I share the code used also in confif.json

{
"recordings_directory":"/srv/recordings",
"finalize_recording_script_path": "/path/to/finalize_recording.sh",

"xmpp_environments": [
                {
                    "name": "mydomain enviroment",
                    "xmpp_server_hosts": [
                            "mydomain.com"
                    ],
                    "xmpp_domain": "mydomain.com",
                    "control_login": {
                        "domain": "auth.mydomain.com",
                        "username": "jibri",
                        "password": "jibriauthpass"
                    },
                    "control_muc": {
                        "domain": "internal.auth.mydomain.com",
                        "room_name": "JibriBrewery",
                        "nickname": "jibri"
                    },
                    "call_login": {
                        "domain": "recorder.mydomain.com",
                        "username": "recorder",
                        "password": "jibrirecorderpass"
                    },
                    "room_jid_domain_string_to_strip_from_start": "conference."
                    "usage_timeout": "0"
                }
      ]
} 

at the moment I have configured the config.json and the jibri.conf.

these are the results when running cat /var/log/jitsi/jibri/log.0.txt y service jibri status

jibri.service - Jibri Process
   Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2020-11-09 14:54:46 -05; 2min 59s ago
  Process: 1490 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
 Main PID: 1490 (code=exited, status=1/FAILURE)

Nov 09 14:54:46 voffic-meet systemd[1]: jibri.service: Service hold-off time over, scheduling restart.
Nov 09 14:54:46 voffic-meet systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Nov 09 14:54:46 voffic-meet systemd[1]: Stopped Jibri Process.
Nov 09 14:54:46 voffic-meet systemd[1]: jibri.service: Start request repeated too quickly.
Nov 09 14:54:46 voffic-meet systemd[1]: jibri.service: Failed with result 'exit-code'.
Nov 09 14:54:46 voffic-meet systemd[1]: Failed to start Jibri Process.

2020-11-09 14:54:45.501 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [--config, /etc/jitsi/jibri/config.json]

thank you for all of your help.

Note: I clarify, I have installed the jitsi and the jibri in the same Ubuntu 18.04 server in Digitalocean.

Don’t use config.json, delete this file.

Use at least 4 cores / 8 GB droplet.

Try to restart jibri

systemctl stop jibri-xorg.service
sleep 5
systemctl start jibri.service
1 Like

@emrah ou are the best … that was the problem, it had the two files the config.json and the jibri.conf … when removing the config.json and restarting the jibri it worked perfectly.

Thank you very much.

1 Like