Help with finding source of error


#1

Hey guys, it’s me again with another little issue.
What do I need to check to get Jitagi to properly work?

SIp client registers with asterisk but I dont see the Invite option in the meeting.
I also cannot get it to answer inbound calls from asterisk.
I have a user sitting in the siptest room, I have also tried with custom invite header…
one error I see is:

2019-01-17 08:37:41.305 SEVERE: [40] org.jitsi.meet.ComponentMain.call().323 not-authorized, host:localhost, port:5347


#2

When I enable the trust for testing it the pcap logs show the call being established, but now the room crashes when a call is made to it.
“Unfortunately, Something went wrong…”

I aslo see:
callcontrol.mydomain.com:component warn Component not connected, bouncing error for: <iq id='LZZEm-1342' type='get' to='callcontrol.mydomain.com' from='focus@auth.mydomain.com/focus20514125826'>

I’m not sure where all these little bits come together … The only reason I did a manual install is so I can customize the main page, but it seems that I’m also finding all the little quirks… luck y me… lol


#3

OK moving along…
I found my call control component wasn’t enabled in (domain)-config.js

I guess thats what casued the auth error…
Thanks for reading along…
now we have this
2019-01-17 09:07:28.402 WARNING: [83] org.jitsi.jigasi.JvbConference.incomingCallReceived().936 Calls not initiated from focus are not allowed

room still crashes when dial in participant tries to join.

Thanks for all of your help.
jon


#4

BAH!!! ok… so when callcontol.domain.com is enabled I dont get the auth error, bt the site doesn’t load at all …
Grr…
What am I doing wrong here??


#5

OK…

I think I have it figured out…

I forgot that the configs I need to change are the ones in the /opt/jitsi-meet/ folder…
changing it in the domain-config file cause conflict when I modify them…
I’m assuming they are all working together but I cannot modify both.
Boy, talk about a learning curve… lol


#6

You don’t need to add anything in config.js jicofo discovers jigasi instances and the option in config.js is not needed.
You need to setup callcontrol component in prosody and its password and make those match those passed to jigasi.


#7

ok… So umm, jicofo doesn’t see jigasi… hmm

Ok so let me run this down with you…
I create the call control component in the [domain]-config.js
and then create the Component “callcontrol.domain.com” component_secret = “secret_password” in /etc/prosody.cfg.lua
As for the jigasi password… is that the “JIGASI_SECRET” in the /etc/jitsi/jigasi/config file?
and if so does it need to be single or double quoted?

Thanks for the help Damian
one issue I has was the site wouldnt load unless I made the changed I had…
I’ll follow your directions to make this right.
jon


#8

I clearly see that there is a problem somewhere but I’m not 100% sure…
FYI: ALWAYS_TRUST_MODE_ENABLED=true is uncommented as well
I realize these are probably two individual issues but I see that the callcontrol component isnt authenticated for some reason and therefore cannot pass calls to the conf room…
I was able to get it to connect when I manually had the lines in the config file uncommented…

|callcontrol.domain.com:component|info|Component authentication failed for callcontrol.domain.com|
|---|---|---|
|Jan 17 12:36:08 mod_component|info|Disconnecting component, <stream:error> is: <stream:error><not-authorized xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match calculated token</text></stream:error>|
|Jan 17 12:36:08 jcp2ceaa10|info|component disconnected: callcontrol.domain.com (false)|

#9

This means that the component password in the prosody config and the one you pass to jigasi is different.


#10

can you explain to me where and how these need to be set… I understand that the prosody config is where I set the one variable. But where is the one that is passed to jigasi configured?


#11

OK I think I found it…
/etc/prosody/conf.avail/[domain].cfg.lua ?


#12

Yes, that is the config for your deployment in prosody.


#13

Ok thanks!
It looks like I have it working now.
I have it registered with my asterisk server and asterisk is sending calls to it as well as attempting to dial out on invite attempts.

Now I need to craft an appropriate IVR scheme to handle the inbound calls.
after reading a few posts it seems that callers may have issues contacting password protected rooms?
What is the best method for securing the site? I have previously tried the secure-site instructional but ended up with some errors. I’ll revisit this method if you feel it will work now.
thanks


#14

Ok I seem to have the secure-domain part somewhat working.
I end up with a “you have been disconnected…” error if I add the "anonymousdomain: ‘guest.domain.com;’ " line in my [domain].config file
but if I put it in my /opt/jitsi-meet/config.js I can secure the room… although at this point everyone needs to log in…
Now how do I get it to secure the creation of the room but allow full access after it has been created?

Thanks Again!..
I’m almost done!


#15

Did you check the javascript console log for errors? Most probably you miss the , at the end of that line.


#16

it’s a little hard to read becasue the page keeps reloading every 5 seconds, but I see Bosh connection failed : host-unknown as one of them


#17

when I comment out the anonymoushost line I get the login again, but same as before… for everyone


#18

wait… rebooting… .I forgot to change the virtualhost in the prosody/conf.avail/…cfg


#19

All good buddy!
I thank you for your hard work and your efforts helping me out.

I think the issue for me is that there are redundant files due to the fact that I have the Manual install and it has the source and easy file payloads.

I hope to be able to get this ironed out soon.
If anyone has an example IVR script kicking around I’d be thrilled to have it.
Thanks again Damian! you are the best.

Sigmaz (jon)