Help to setup driver for Camera, Microphone and Audio output

Hi everybody!
I embeded jitsi on MVC website using guide in this link https://github.com/jitsi/jitsi-meet/blob/master/doc/api.md, when open room i got message Failed to access your microphone and Failed to access your camera. I went to Setting then i got Permission not granted for all devices. Anybody can help me fix it. Thank you!

What browser did you use when you got this error? Try Chrome as it works best for Jitsi.

I used Chrome.

1 Like

One of my visitors using Chrome version 83 reported the same issue, they could see the video but was unable to enable Audio, they reported the same Permission not granted for Audio output under settings.

Other users also using Chrome did not see this error and can see Video and hear Audio fine.

Can you check if audio is disabled for chrome at your windows system audio settings?

Chrome sound setting and system sound were enabled for Chrome. In another case i just opened html file in local folder, it worked for me. Problem was when embeded on MVC

systemsound

Can you check if Windows Microphone privacy settings are blocking your microphone?
https://support.google.com/chrome/thread/2062037?hl=en&msgid=28511121

Search (win+S) 'Microphone privacy settings'
Check 'Microphone access for this device is On/Off' 
Change to 'On'
Then scroll down to 'Allow desktop apps to access your microphone'
Turn 'On'

Another thing to test:
can you open https://test.webrtc.org , click Start and then send us the report?

Here’s my test report

[{“title”:“WebRTC Troubleshooter bug report”,“description”:null},
{“ts”:1585292486828,“name”:“system-info”,“args”:{“browserName”:“Chrome”,“browserVersion”:“80.0.3987.149”,“platform”:“Win32”}},
{“ts”:1585292503083,“name”:“enumerateDevices”,“id”:1,“args”:“Some other kind of source: audiooutput”},
{“ts”:1585292503083,“name”:“enumerateDevices”,“id”:1,“args”:“Some other kind of source: audiooutput”},
{“ts”:1585292503083,“name”:“enumerateDevices”,“id”:1,“args”:“Some other kind of source: audiooutput”},
{“ts”:1585292505146,“name”:“test-run”,“id”:2,“args”:{“name”:“Audio capture”,“status”:“running”}},
{“ts”:1585292505165,“name”:“getusermedia”,“id”:3,“args”:{“status”:“pending”,“constraints”:{“audio”:{“optional”:[{“echoCancellation”:false},{“sourceId”:“default”}]}}}},
{“ts”:1585292505246,“name”:“getusermedia”,“id”:3,“args”:{“status”:“success”,“camera”:null,“microphone”:“Default - Microphone Array (Realtek Audio)”}},
{“ts”:1585292505246,“name”:“test-run”,“id”:2,“args”:{“success”:“Audio track created using device=Default - Microphone Array (Realtek Audio)”}},
{“ts”:1585292507261,“name”:“test-run”,“id”:2,“args”:{“info”:“Channel 0 levels: -21.2 dB (peak), -30.9 dB (RMS)”}},
{“ts”:1585292507271,“name”:“test-run”,“id”:2,“args”:{“info”:“Channel 1 levels: -21.2 dB (peak), -30.9 dB (RMS)”}},
{“ts”:1585292507275,“name”:“test-run”,“id”:2,“args”:{“success”:“Active audio input channels: 2”}},
{“ts”:1585292507281,“name”:“test-run”,“id”:2,“args”:{“info”:“Stereo microphone detected.”}},
{“ts”:1585292507282,“name”:“test-run”,“id”:2,“args”:{“status”:“success”}},
{“ts”:1585292507302,“name”:“test-run”,“id”:4,“args”:{“name”:“Check resolution 320x240”,“status”:“running”}},
{“ts”:1585292507339,“name”:“call”,“id”:5,“args”:{“config”:null}},
{“ts”:1585292507346,“name”:“call”,“id”:5,“args”:{“state”:“start”}},
{“ts”:1585292515350,“name”:“call”,“id”:5,“args”:{“state”:“end”}},
{“ts”:1585292515413,“name”:“video-stats”,“args”:{“cameraName”:“Integrated Webcam (1bcf:2b91)”,“actualVideoWidth”:320,“actualVideoHeight”:240,“mandatoryWidth”:320,“mandatoryHeight”:240,“encodeSetupTimeMs”:null,“avgEncodeTimeMs”:null,“minEncodeTimeMs”:null,“maxEncodeTimeMs”:null,“avgInputFps”:null,“minInputFps”:null,“maxInputFps”:null,“avgSentFps”:null,“minSentFps”:null,“maxSentFps”:null,“isMuted”:false,“testedFrames”:276,“blackFrames”:2,“frozenFrames”:1}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“cameraName: Integrated Webcam (1bcf:2b91)”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“actualVideoWidth: 320”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“actualVideoHeight: 240”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“mandatoryWidth: 320”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“mandatoryHeight: 240”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“isMuted: false”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“testedFrames: 276”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“blackFrames: 2”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“frozenFrames: 1”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“Not available: encodeSetupTimeMs, avgEncodeTimeMs, minEncodeTimeMs, maxEncodeTimeMs, avgInputFps, minInputFps, maxInputFps, avgSentFps, minSentFps, maxSentFps”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“info”:“Cannot verify sent FPS.”}},
{“ts”:1585292515413,“name”:“test-run”,“id”:4,“args”:{“success”:“Captured video using expected resolution.”}},
{“ts”:1585292515414,“name”:“test-run”,“id”:4,“args”:{“status”:“success”}},
{“ts”:1585292515422,“name”:“test-run”,“id”:6,“args”:{“name”:“Check resolution 640x480”,“status”:“running”}},
{“ts”:1585292515458,“name”:“call”,“id”:7,“args”:{“config”:null}},
{“ts”:1585292515463,“name”:“call”,“id”:7,“args”:{“state”:“start”}},
{“ts”:1585292523468,“name”:“call”,“id”:7,“args”:{“state”:“end”}},
{“ts”:1585292523570,“name”:“video-stats”,“args”:{“cameraName”:“Integrated Webcam (1bcf:2b91)”,“actualVideoWidth”:640,“actualVideoHeight”:480,“mandatoryWidth”:640,“mandatoryHeight”:480,“encodeSetupTimeMs”:null,“avgEncodeTimeMs”:null,“minEncodeTimeMs”:null,“maxEncodeTimeMs”:null,“avgInputFps”:null,“minInputFps”:null,“maxInputFps”:null,“avgSentFps”:null,“minSentFps”:null,“maxSentFps”:null,“isMuted”:false,“testedFrames”:211,“blackFrames”:3,“frozenFrames”:2}},
{“ts”:1585292523570,“name”:“test-run”,“id”:6,“args”:{“info”:“cameraName: Integrated Webcam (1bcf:2b91)”}},
{“ts”:1585292523570,“name”:“test-run”,“id”:6,“args”:{“info”:“actualVideoWidth: 640”}},
{“ts”:1585292523570,“name”:“test-run”,“id”:6,“args”:{“info”:“actualVideoHeight: 480”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“mandatoryWidth: 640”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“mandatoryHeight: 480”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“isMuted: false”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“testedFrames: 211”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“blackFrames: 3”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“frozenFrames: 2”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“Not available: encodeSetupTimeMs, avgEncodeTimeMs, minEncodeTimeMs, maxEncodeTimeMs, avgInputFps, minInputFps, maxInputFps, avgSentFps, minSentFps, maxSentFps”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“info”:“Cannot verify sent FPS.”}},
{“ts”:1585292523571,“name”:“test-run”,“id”:6,“args”:{“success”:“Captured video using expected resolution.”}},
{“ts”:1585292523573,“name”:“test-run”,“id”:6,“args”:{“status”:“success”}},
{“ts”:1585292523592,“name”:“test-run”,“id”:8,“args”:{“name”:“Check resolution 1280x720”,“status”:“running”}},
{“ts”:1585292523627,“name”:“call”,“id”:9,“args”:{“config”:null}},
{“ts”:1585292523630,“name”:“call”,“id”:9,“args”:{“state”:“start”}},
{“ts”:1585292531657,“name”:“call”,“id”:9,“args”:{“state”:“end”}},
{“ts”:1585292531785,“name”:“video-stats”,“args”:{“cameraName”:“Integrated Webcam (1bcf:2b91)”,“actualVideoWidth”:1280,“actualVideoHeight”:720,“mandatoryWidth”:1280,“mandatoryHeight”:720,“encodeSetupTimeMs”:null,“avgEncodeTimeMs”:null,“minEncodeTimeMs”:null,“maxEncodeTimeMs”:null,“avgInputFps”:null,“minInputFps”:null,“maxInputFps”:null,“avgSentFps”:null,“minSentFps”:null,“maxSentFps”:null,“isMuted”:false,“testedFrames”:126,“blackFrames”:2,“frozenFrames”:1}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“cameraName: Integrated Webcam (1bcf:2b91)”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“actualVideoWidth: 1280”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“actualVideoHeight: 720”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“mandatoryWidth: 1280”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“mandatoryHeight: 720”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“isMuted: false”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“testedFrames: 126”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“blackFrames: 2”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“frozenFrames: 1”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“Not available: encodeSetupTimeMs, avgEncodeTimeMs, minEncodeTimeMs, maxEncodeTimeMs, avgInputFps, minInputFps, maxInputFps, avgSentFps, minSentFps, maxSentFps”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“info”:“Cannot verify sent FPS.”}},
{“ts”:1585292531786,“name”:“test-run”,“id”:8,“args”:{“success”:“Captured video using expected resolution.”}},
{“ts”:1585292531806,“name”:“test-run”,“id”:8,“args”:{“status”:“success”}},
{“ts”:1585292531819,“name”:“test-run”,“id”:10,“args”:{“name”:“Check supported resolutions”,“status”:“running”}},
{“ts”:1585292531853,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 160x120”}},
{“ts”:1585292531891,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 160x120”}},
{“ts”:1585292531924,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 320x180”}},
{“ts”:1585292531957,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 320x240”}},
{“ts”:1585292531991,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 640x360”}},
{“ts”:1585292532025,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 640x480”}},
{“ts”:1585292532058,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 768x576”}},
{“ts”:1585292532090,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 1024x576”}},
{“ts”:1585292532123,“name”:“test-run”,“id”:10,“args”:{“success”:“Supported: 1280x720”}},
{“ts”:1585292532125,“name”:“test-run”,“id”:10,“args”:{“info”:“1280x768 not supported”}},
{“ts”:1585292532126,“name”:“test-run”,“id”:10,“args”:{“info”:“1280x800 not supported”}},
{“ts”:1585292532127,“name”:“test-run”,“id”:10,“args”:{“info”:“1920x1080 not supported”}},
{“ts”:1585292532128,“name”:“test-run”,“id”:10,“args”:{“info”:“1920x1200 not supported”}},
{“ts”:1585292532129,“name”:“test-run”,“id”:10,“args”:{“info”:“3840x2160 not supported”}},
{“ts”:1585292532129,“name”:“test-run”,“id”:10,“args”:{“info”:“4096x2160 not supported”}},
{“ts”:1585292532130,“name”:“test-run”,“id”:10,“args”:{“status”:“success”}},
{“ts”:1585292532146,“name”:“test-run”,“id”:11,“args”:{“name”:“Udp enabled”,“status”:“running”}},
{“ts”:1585292532552,“name”:“fetch-ice-config”,“args”:“Fetching new credentials.”},
{“ts”:1585292532553,“name”:“turn-config”,“args”:{“iceServers”:[{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}},
{“ts”:1585292532746,“name”:“test-run”,“id”:11,“args”:{“success”:“Gathered candidate of Type: relay Protocol: udp Address: 64.233.188.85”}},
{“ts”:1585292532749,“name”:“test-run”,“id”:11,“args”:{“status”:“success”}},
{“ts”:1585292532754,“name”:“test-run”,“id”:12,“args”:{“name”:“Tcp enabled”,“status”:“running”}},
{“ts”:1585292532754,“name”:“fetch-ice-config”,“args”:“Using cached credentials.”},
{“ts”:1585292532754,“name”:“turn-config”,“args”:{“iceServers”:[{“urls”:[“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}},
{“ts”:1585292533035,“name”:“test-run”,“id”:12,“args”:{“success”:“Gathered candidate of Type: relay Protocol: udp Address: 74.125.39.56”}},
{“ts”:1585292533038,“name”:“test-run”,“id”:12,“args”:{“status”:“success”}},
{“ts”:1585292533042,“name”:“test-run”,“id”:13,“args”:{“name”:“Ipv6 enabled”,“status”:“running”}},
{“ts”:1585292533151,“name”:“test-run”,“id”:13,“args”:{“warning”:“Failed to gather IPv6 candidates, it might not be setup/supported on the network.”}},
{“ts”:1585292533151,“name”:“test-run”,“id”:13,“args”:{“status”:“warning”}},
{“ts”:1585292533164,“name”:“test-run”,“id”:14,“args”:{“name”:“Relay connectivity”,“status”:“running”}},
{“ts”:1585292533165,“name”:“fetch-ice-config”,“args”:“Using cached credentials.”},
{“ts”:1585292533165,“name”:“turn-config”,“args”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}},
{“ts”:1585292533165,“name”:“call”,“id”:15,“args”:{“config”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}}},
{“ts”:1585292533168,“name”:“call”,“id”:15,“args”:{“state”:“start”}},
{“ts”:1585292533389,“name”:“test-run”,“id”:14,“args”:{“info”:“Gathered candidate of Type: relay Protocol: udp Address: 74.125.39.56”}},
{“ts”:1585292533471,“name”:“test-run”,“id”:14,“args”:{“info”:“Gathered candidate of Type: relay Protocol: udp Address: 64.233.188.87”}},
{“ts”:1585292538169,“name”:“test-run”,“id”:14,“args”:{“error”:“Timed out”}},
{“ts”:1585292538169,“name”:“call”,“id”:15,“args”:{“state”:“end”}},
{“ts”:1585292538175,“name”:“test-run”,“id”:14,“args”:{“status”:“failure”}},
{“ts”:1585292538183,“name”:“test-run”,“id”:16,“args”:{“name”:“Reflexive connectivity”,“status”:“running”}},
{“ts”:1585292538184,“name”:“fetch-ice-config”,“args”:“Using cached credentials.”},
{“ts”:1585292538184,“name”:“turn-config”,“args”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}},
{“ts”:1585292538184,“name”:“call”,“id”:17,“args”:{“config”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}}},
{“ts”:1585292538188,“name”:“call”,“id”:17,“args”:{“state”:“start”}},
{“ts”:1585292538281,“name”:“test-run”,“id”:16,“args”:{“info”:“Gathered candidate of Type: srflx Protocol: udp Address: 118.70.203.242”}},
{“ts”:1585292538283,“name”:“test-run”,“id”:16,“args”:{“info”:“Gathered candidate of Type: srflx Protocol: udp Address: 118.70.203.242”}},
{“ts”:1585292543190,“name”:“test-run”,“id”:16,“args”:{“warning”:“Could not connect using reflexive candidates, likely due to the network environment/configuration.”}},
{“ts”:1585292543190,“name”:“call”,“id”:17,“args”:{“state”:“end”}},
{“ts”:1585292543196,“name”:“test-run”,“id”:16,“args”:{“status”:“warning”}},
{“ts”:1585292543205,“name”:“test-run”,“id”:18,“args”:{“name”:“Host connectivity”,“status”:“running”}},
{“ts”:1585292543206,“name”:“call”,“id”:19,“args”:{}},
{“ts”:1585292543209,“name”:“call”,“id”:19,“args”:{“state”:“start”}},
{“ts”:1585292543220,“name”:“test-run”,“id”:18,“args”:{“info”:“Gathered candidate of Type: host Protocol: udp Address: 10.151.138.153”}},
{“ts”:1585292543221,“name”:“test-run”,“id”:18,“args”:{“info”:“Gathered candidate of Type: host Protocol: udp Address: 10.151.138.182”}},
{“ts”:1585292543222,“name”:“test-run”,“id”:18,“args”:{“info”:“Gathered candidate of Type: host Protocol: udp Address: 10.151.143.41”}},
{“ts”:1585292543279,“name”:“test-run”,“id”:18,“args”:{“success”:“Data successfully transmitted between peers.”}},
{“ts”:1585292543279,“name”:“call”,“id”:19,“args”:{“state”:“end”}},
{“ts”:1585292543287,“name”:“test-run”,“id”:18,“args”:{“status”:“success”}},
{“ts”:1585292543304,“name”:“test-run”,“id”:20,“args”:{“name”:“Data throughput”,“status”:“running”}},
{“ts”:1585292543305,“name”:“fetch-ice-config”,“args”:“Using cached credentials.”},
{“ts”:1585292543305,“name”:“turn-config”,“args”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}},
{“ts”:1585292543306,“name”:“call”,“id”:21,“args”:{“config”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}}},
{“ts”:1585292543310,“name”:“call”,“id”:21,“args”:{“state”:“start”}},
{“ts”:1585292545159,“name”:“test-run”,“id”:20,“args”:{“success”:“Transmitting at 634.478 kbps.”}},
{“ts”:1585292546229,“name”:“test-run”,“id”:20,“args”:{“success”:“Transmitting at 826.856 kbps.”}},
{“ts”:1585292547267,“name”:“test-run”,“id”:20,“args”:{“success”:“Transmitting at 1033.865 kbps.”}},
{“ts”:1585292548304,“name”:“test-run”,“id”:20,“args”:{“success”:“Transmitting at 1177.057 kbps.”}},
{“ts”:1585292549331,“name”:“test-run”,“id”:20,“args”:{“success”:“Transmitting at 1427.817 kbps.”}},
{“ts”:1585292549897,“name”:“call”,“id”:21,“args”:{“state”:“end”}},
{“ts”:1585292549914,“name”:“test-run”,“id”:20,“args”:{“success”:“Total transmitted: 6144 kilo-bits in 5.758 seconds.”}},
{“ts”:1585292549915,“name”:“test-run”,“id”:20,“args”:{“status”:“success”}},
{“ts”:1585292549923,“name”:“test-run”,“id”:22,“args”:{“name”:“Video bandwidth”,“status”:“running”}},
{“ts”:1585292549925,“name”:“fetch-ice-config”,“args”:“Using cached credentials.”},
{“ts”:1585292549926,“name”:“turn-config”,“args”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}},
{“ts”:1585292549926,“name”:“call”,“id”:23,“args”:{“config”:{“iceServers”:[{“urls”:[“stun:108.177.125.127:19302”,“stun:[2404:6800:4008:c01::7f]:19302”]},{“urls”:[“turn:64.233.188.127:19305?transport=udp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=udp”,“turn:64.233.188.127:19305?transport=tcp”,“turn:[2404:6800:4008:c06::7f]:19305?transport=tcp”],“username”:“CPPs+/MFEgZGGBJTmr8YqvGggqMKIICjBQ”,“credential”:“K5hNby1wRKYR6Qof8iwu2NtyoIM=”,“maxRateKbps”:“8000”}]}}},
{“ts”:1585292549929,“name”:“getusermedia”,“id”:24,“args”:{“status”:“pending”,“constraints”:{“audio”:false,“video”:{“optional”:[{“minWidth”:1280},{“minHeight”:720},{“sourceId”:“03f4e2fbb1c03a001ed942c97b38ac851c9c59185fab4915fe9691ce4b302eaf”}]}}}},
{“ts”:1585292549964,“name”:“getusermedia”,“id”:24,“args”:{“status”:“success”,“camera”:“Integrated Webcam (1bcf:2b91)”,“microphone”:null}},
{“ts”:1585292549966,“name”:“call”,“id”:23,“args”:{“state”:“start”}}]

I am clueless why you get the permission denied “Failed to access your microphone and Failed to access your camera” when using the JitsiMeetExternalAPI inside your ASP .NET “MVC” website.

The webrtc test log looks ok. and as you say the camera and microphone work ok when using chrome and meet.jit.si .

A long shot: I notice the following in your picture:
you are trying to setup a demo website, “demo.jitsi.com” on your own machine, without using SSL “Not secure” when you get the permission denied error for microphone and camera. I think the SSL setup error may be related because webrtc need SSL to function properly.

If you can setup a public website with SSL that are using the extenal JitsiMeetExternalAPI that show the same behaviour then I and others may take a look at it.

I had the same problem. I discovered the problem which I find strange that nobody can explain. all browsers only send a request for a microphone and camera if they have a secure connection (SSL). Otherwise, this permission error occurs. Either SSL is generated for the server or you can work around it for testing. In chrome enter the option (chrome://flags/#unsafel\y-treat-insecure-origin-as-secure) and activate it, add http://domain.com or http://domain.com:8080
Ready.