[HELP] Stops work with new CHROME version 86.0.4240.75

Hello Guys.

After I update my google chrome to version: 86.0.4240.75

I simply can’t use jitsy anymore, I get this message:

"Failed to acces your microphone: Cannot use your microphone for an unknown reason. Failed to execute ‘CreateEncodedStreams’ on RTCRtpSender: Encoded audio streams not requested at PC inicialization image

1 Like

This is other error i’m getting

image

But i set all microfone permitions on my computer, I can perfectly use others application, such as whastapp web, and google hangouts normaly

@Igor_Ayres, can you please add the steps for reproduction and add more details about your client machine ? I am not able to reproduce this issue using the exact same version of Chrome running on macOS 10.15.7 and Windows10.

sure! Witch informations do you need on my client machine?

This error accours on a Linux mint 19 machine, also on a windows 10 64 bits

@Igor_Ayres, I could not reproduce it on Win10 64-bit laptop ? Did you do something differently other than joining a call ? Did you enable end-to-end encryption from the security settings ?

This is weird because I make absolutely no changes on this server… I just try to conect on a room, and this happens. I have a few members on my team, and this its happenig for a few of then.

Some PC with the same chrome version, and SO can, and the others don’t.

What informations do you need?

I just confirmed this is a chrome version problem…

I install the previous version ( 84.0.4147.135) and work just fine…

Also, no problem with firefox or edge browser…

Funny, that’s not happening with all new chrome versions… Any gueses?

Are you seeing this on meet.jit.si or on your own deployment ?

my own

Are you able to reproduce it on https://meet.jit.si ? If not, you might have to update your client on your deployment to the latest stable version since at some point Chrome changed the way we create encoded streams for end-to-end encryption to work.

We are facing the same issue since this morning, with chrome 86.

UnhandledError: Uncaught InvalidStateError: Failed to execute ‘createEncodedStreams’ on ‘RTCRtpReceiver’: Encoded audio streams not requested at PC initialization Script: v=139 Line: 17 Column: 26242 StackTrace: DOMException: Failed to execute ‘createEncodedStreams’ on ‘RTCRtpReceiver’: Encoded audio streams not requested at PC initialization
at a.handleReceiver

Our deployment use 2.1-202-g5f9377b9(jitsi-meet_4627)

We cannot update to the last version easily, @jallamsetty could you point us to the changes that fix the creation of encoded streams ?

Hello. Any ideas?

Chrome on Mac (86.0.4240.75 (Official Build) (x86_64)) shows only the own, local stream, any incomming remote stream (video+audio) is “muted”

Chrome ErrorLog:

[28957:77315:1008/155855.773274:ERROR:internal_decoder_factory.cc(59)] Trying to create decoder for unsupported format
[28957:77315:1008/155855.774353:ERROR:webrtc_video_engine.cc(3327)] Absent receive stream; ignoring clearing encoded frame sink for ssrc 0

Actually, you will have to update to a version released after July 14th to be able to fix this issue, there is no way around it - https://github.com/jitsi/lib-jitsi-meet/commit/1c4622c865d2a848716f178ad102bcb7455aea81

1 Like

There is some update tutorial?

We are facing the same issue; Chrome version 85 worked fine but 86 fails with both audio and video streams even locally. We are running the latest Jitsi components from the stable repo.

For the record we are using http-bind and not websockets should it matter here.

EDIT: Our issue was solved. The problem was web server CSP and E2EEContext.js.

For the record, our issue was CSP (content-security-policy) based. We had set a custom CSP to our web server proxy in front of Jitsi. The issue was with child-src and worker-src directives. Latter was missing and child-src was just ‘self’. The error was:

E2EEContext.js:55 Refused to create a worker from ‘blob:https://xxxx.yyyy.xy/ba779621-af23-4fb9-9e3f-ec2d2d73ba6be’ because it violates the following Content Security Policy directive: “child-src ‘self’”. Note that ‘worker-src’ was not explicitly set, so ‘child-src’ is used as a fallback.

We added worker-src 'self' blob:; to the CSP and Jitsi is working again.

I suppose that you are using jitsi-meet. You need to build/install the version which have the fix. Jitsi-meet is using lib-jitsi-meet library. I thik this is the proper version jitsi-meet_2.0.4857-1_all.deb (https://download.jitsi.org/stable/jitsi-meet_2.0.4857-1_all.deb)
here are the stable versions to download https://download.jitsi.org/stable/

Because jitsi-meet depends on lib-jitsi-meet library - and you need the proper version where the problem is fixed

Thank you very much !

While looking around the change in those files, I found another way to fix it for our case (jitsi v42_27), by applying this commit:

1 Like

Thanks,

As our code is very old and customized, we can’t merge new commits.
So what i did to fix this issue is .

  1. Setup jitsi meet library on local.
  2. Checkout to the commit used in our project.
  3. Applied your fix.
  4. Created new minified build of library.
  5. Replaced on server.

Finally its working now,

2 Likes