Help: Recorders not avaliable (custom deployment)

Your domain name is the problem, buddy.

Are you able to make calls on Jitsi? 2 participant call? Then 3 participant call?

yeah, I’ll privatly dm you my domain

Ok.

The problem from your log starts from here:

2020-11-21 09:18:17.177 WARNING: [27] org.jitsi.xmpp.mucclient.MucClient.log() [MucClient id=“my.domain.com” hostname=“my.domain.com”] error connecting

  • Is jibri on a different server?

  • Is TCP/5222 open on JMS?

  • Does jibri ping to the JMS using the domain address?

how do I check these?

On the jibri server

apt-get install curl

curl http://your.domain.com:5222/
ping your.domain.com
<?xml version='1.0'?><stream:stream xmlns:stream='http://etherx.jabber.org/streams' xml:lang='en' xmlns='jabber:client'><stream:error><not-well-formed xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error></stream:stream> 
4 packets transmitted, 4 received, 0% packet loss, time 3076ms
rtt min/avg/max/mdev = 0.011/0.011/0.013/0.004 ms

On the jibri server?

The jibri server is on the jitsi server

So did you run this command on the server with the domain address?
Not from your desktop machine…
Not with IP address…

Yes, I went on my ssh server and did the comma ds

According to the log my.domain.com is failed for jibri. But according to the tests:

  • my.domain.com is resolvable for jibri
  • TCP/5222 is accessable for jibri
  • prosody is up

Might be a bug?

Or a typo

There’s almost definitely some typo somewhere. Check your lua configuration:

– internal muc component, meant to enable pools of jibri and jigasi clients
Component “internal.auth.my.domain.com” “muc”
modules_enabled = {
“ping”;
}
storage = “memory”
muc_room_cache_size = 1000

VirtualHost “recorder.my.domain.com
modules_enabled = {
“ping”;
}
authentication = “internal_plain”

Could you check the double primes in your jibri.conf

it’s working kind of now. It’s now saying it failed to start here’s the log:

2020-11-21 19:25:41.010 INFO: [1] org.jitsi.jibri.Main.handleCommandLineArgs() Jibri run with args [--config, /etc/jitsi/jibri/config.json]
2020-11-21 19:25:41.049 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Checking legacy config file /etc/jitsi/jibri/config.json
2020-11-21 19:25:41.050 INFO: [1] org.jitsi.jibri.Main.setupLegacyConfig() Legacy config file /etc/jitsi/jibri/config.json doesn't exist
2020-11-21 19:25:41.379 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.Companion.fromConfig() got jwtConfig: {}

2020-11-21 19:25:41.380 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.Companion.fromConfig() Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: reference.conf @ jar:file:/opt/jitsi/jibri/jibri.jar!/reference.conf: 52: No configuration setting found for key 'signing-key-path'
2020-11-21 19:25:41.446 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2020-11-21 19:25:41.457 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status
2020-11-21 19:25:41.614 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-11-21 19:25:41.618 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for HTTP API
2020-11-21 19:26:41.444 FINE: [18] org.jitsi.jibri.webhooks.v1.WebhookClient.invokeSuspend() Updating 0 subscribers of status

Now, go and check your Jibri.conf; since you started over, the file may be empty.

By the way, that’s not your full Jibri log.