Help, please. Recurring jitsi failure

Hi Team

We have used Jitsi in our school with great results in video conferences of up to 70 participants.

However, yesterday I changed the server and the installation seemed fine until during a class with only 20 participants, the audio started to be interrupted until it was impossible to continue. Then the room was restarted again and again.

I checked the logs and found no errors in prosody or jicofo but the jvb log grew to 384 MB. The problem is that I’m new to this and I can’t interpret it but there are messages that are recurring.

I am attaching a part of the log to see if anyone can help us discover the problem please.

CPU 4 cores, 8GB RAM, 200 GB SSD, 200 Mbit/s port
Debian 10
openjdk version “11.0.8” 2020-07-14
jitsi-meet 2.0.4966-1
jitsi-meet-prosody 1.0.4370-1
jitsi-videobridge2 2.1-304-g8488f77d-1
prosody 0.11.2-1

jvb.log (42.7 KB)

Hi @Richardmax,
Actually, your current infrastructure is not okay for 70 users. Try to add additional JVB and after that try to enable OCTO.

Hi @akalana

We had 70 users and it worked ok but now we only allow 40. Anyway, this error happens only with 14 users

@bbaldino @Boris_Grozev Same error surface here:

Exception in thread "Global IO pool-487524" java.lang.NoClassDefFoundError: Could not initialize class com.fasterxml.jackson.databind.deser.std.JdkDeserializers
1 Like

same error @damencho

1 Like

Hello
I know that it’s not a proper fix but you are in a difficult situation and sometimes you have to try anything to make it work so maybe you could try to install java 8, use update-alternatives to select it and reboot. Astonishing it could be but Jitsi devs have repeatedly stated that they are sticking to java 8 so maybe a code change they have done recentely is not fully compatible with java 11.

1 Like

Thank you @gpatel-fr

I read in this community that Jibri works with java 8 but in the case of Jitsi the documentation (quick install) does not refer to the java version and I respected all the steps to install it.

There is a reference in the manual installation guide (Install JRE if missing: apt-get install openjdk-8-jre ) but that page has a warning in the header that says “MANUAL INSTALLATION IS NOT RECOMMENDED”.

So you recommend me to download the java version to 8? Won’t it affect the platform even more?

I’d definitely use Java 8.

Thank you all for your help.

I reset all. Install Java 8 and jitsi fresh but now appear a warning in jitsi log:

Prosody

See the attached log

jvb2.txt (3.6 KB) jicofo.log (6.5 KB)

Well, if this operation did appear to be what I suggested you to do, it was definitely a mistake of my part.
Anyway, here are my notes on ‘un-installing everything jitsi-related to install it fresh’

sudo apt purge jitsi-meet jitsi-meet-prosody jitsi-meet-web-config ca-certificates-java java-common openjdk-8-jre-headless jitsi-videobridge2 jicofo coturn jitsi-meet-turnserver prosody certbot
echo PURGE |  sudo debconf-communicate jitsi-videobridge

it may be overkill but if you don’t remove ca-certificates-java you can expect funny things.

Thanks for support me @gpatel-fr

I had reinstall all server again Debian, Java 8 and Jitsi. The last warning persists for jitsi, jicofo and prosody :exploding_head:

I’d say this is your issue, but I’m not sure if there’s anything specific you have to do on the jitsi side for this or if this is a more general config thing. @damencho do you know?

Well, situation does not come any better then. Installing java 8 has not shown the same problem but it’s another one now… It seems to be a recurring problem with Debian from this forum history. The idea is that the Prosody certificates (should be under /var/lib/prosody/ with a name like auth.yoururl.crt) is not added to the system (Java ?) store. Check that this certificate is in the /etc/ssl/certs/ca-certificates.crt global list. (probably at the end)
If it’s not it should be added by running sudo update-ca-certificates. If it’s not added (0 done) there should be a problem in the paths somewhere. Report.

Hi @gpatel-fr, @bbaldino

After so many frustrations, I decided to remove Debian and install Ubuntu 18.04 and Java 8. For now everything works fine but only Jicofo shows a “SEVERE” error. I don’t know how bad it will be.

Thanks for your support!!


Jicofo 2020-09-10 02:30:12.521 SEVERE: [31] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused (Connection refused)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:296)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:285)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:607)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)

It can’t connect to your XMPP server. Is your XMPP server hosted on localhost:5347 on the machine Jicofo is running on?

Hi @bbaldino

Forgive my ignorance in the matter but I have no idea. I just followed the step-by-step of “Self-Hosting Guide - Debian/Ubuntu server” at https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstar

I did not make any other changes than those indicated in the documentation for Secure Domain setup at https://jitsi.github.io/handbook/docs/devops-guide/secure-domain

There is only reference to XMMP in Jicofo configuration at https://jitsi.github.io/handbook/docs/devops-guide/secure-domain#jicofo-configuration

org.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

Thank you very much

My understanding (correct me if I am wrong) is that Jicofo will try to connect to Prosody (XMPP) in two ways, as an internal component and as a MUC user… If one of them fails it gives you this error but if the other method works, Jitsi-meet will work anyways.

You are on secure domain right? If so, keep reading
I had the same issue in the past and @damencho told me I could ignore the error, even though it says “SEVERE” :slight_smile:
To get rid of the error, you have to make sure that you have a (virtual)user in prosody for jicofo and that the jicofo config uses the same password as the one in the focus.dat file in
/var/lib/prosody/[auth%2eyourdomain%2ecom]/accounts
(dots are replaced by %2e in the domain name, but basicaly, auth.yourdomain.com)
Password is scrambled using base64 in the file. You can google “base64 decode” and you will see if it matches.

Thanks for comment @Normand_Nadon

I understand but generally, it is not expected that after a quick step-by-step installation guide, there will be “SEVERE” notifications.

After so many days of dealing with errors, I prefer to wait until it is documented.

I understand but generally, it is not expected that after a quick step-by-step installation guide, there will be “SEVERE” notifications.

Welcome to Jitsi! :smiley:… I learned to roll with it as time passed :stuck_out_tongue:
The dev are hard at work, but it still is a free project in the end. But, it delivers incredible features and performance. It does come with a darker side though!

After so many days of dealing with errors, I prefer to wait until it is documented.

Hum, how long are you ready to wait? I have to say, documentation has come a long way in a couple of months, but it is still not the strongest point for Jitsi for now!
There are plenty of forum threads on the subject that popped over the summer… You should find fresh information there.

God Speed my friend!

I agree :wink: