Help noob for fresh install

Hi
Im noob

for coronavirus quarantine i choose to get a tiny server and install jitsi for all familly video conf

i can install whatever distrib and choosed desbian 10

i’ve installed virtualmin bundle LEMP ,
created mydomain virtualhost
created video. mydomain sub-server
ok
installed jitsi quick install script on hostname: video.mydomain : no errors
but nothing … nothing come on video.mydomain
and jitsi install seems to delete the nginx subdomain conf …

no error and nothing.

please, can someone share a tutorial on How the fastest get a jitsi-meet server knowing :

  • having an empty server, all distrib possible (so what is the best one ?)
  • having a domain name for custom website and subdomain for jitsi

to can say : hey dad ! just go on video.mydomain !

thank you

Install on Ubunuto 18.04, have a domain with DNS entry ready, follow https://jitsi.org/qi filling in that domain name when asked.

  • I saw that Ununto 18 doesn’t have Java8 and has java11, is it true that Jitsi need it ? (so need to be installed)

Yes.

Finally how i done : To get a jitsi server on a fresh dedicated server install with virtualmin/webmin (assuming im noob) :

  • Ubuntu 18 & 16 : encounter virtualmin problem for nslookup…

  • debian 9.4 : other virtualmin problem …

  • debian 10 : great : virtualmin install LAMP

  • virtualmin : created a virtualserver on myDomain

  • virtualmin : created an “alias” subserver on meet.myDomain <= this is important

  • install jitsi-meet on meet.myDomain (i forgot to install java8 and no complain so…)

  • install succesfull but
    => failure : apache2 meet.myDomain.conf seems ok, with jitsi configuration, but redirect to default myDomain

  • trick : edit meet.myDomain with virtualmin and click “convert” the alias as a subserver
    => http//meet.myDomain works !

  • launch de Jitsi certificate process

=> done !

meet.myDomain => JITSI
myDomain => LAMP

ADDED : Java8 is important even the install doesn’t complain

EDIT:

  • debian 10 need a custom trick to install libssl1 for jitsi-meet-token because libssl1.0 is not in “buster” source

  • then muc_size is by default (with token modules) with prosody module , dont need to download them

I was unable to repeat your success, @ledahu on Virtualmin on Debian 10 and from my understanding of how Virtualmin works and Jitsi is configured, I am surprised that the steps you have outlined worked at all. Anyway.

Here is what worked for me on Ubuntu and I expect it will work on Debian too:

  1. Install Jitsi on Ubuntu (I used 18 LTS with Virtualmin loaded and configured) with instructions from jitsi quick-install. Be sure to remember the hostname you have entered.

  2. Changed Webmin port from 10000 to 10001. Open 10001 port on cloud network firewall and vps firewall. Reconnect to Webmin web interface on 10001. Open 4443 port on cloud network firewall and vps firewall. Keep port 443 open. Open port 10000 UDP on cloud network firewall and vps firewall.

  3. In Webmin | Servers | Apache | Existing Virtual Hosts, find the entry for the hostname you have used in Step 1. Select it and delete it.

  4. In Virtualmin create a virtual server with the hostname you have used in Step 1. Under Enabled Features, use whichever options you like but be sure to check Enable SSL for website. Create server.

  5. In Virtualmin, under the hostname you have just created, in Services | Configure SSL Website | Edit Directives. Comment out existing DocumentRoot, add in the line below it all the following lines…

    DocumentRoot “/usr/share/jitsi-meet”

    <Directory “/usr/share/jitsi-meet”>
    Options Indexes MultiViews Includes FollowSymLinks
    AddOutputFilter Includes html
    AllowOverride All
    Order allow,deny
    Allow from all

    ErrorDocument 404 /static/404.html

    Alias “/config.js” “/etc/jitsi/meet/jitsi.indiax.com-config.js”
    <Location /config.js>
    Require all granted

    Alias “/external_api.js” “/usr/share/jitsi-meet/libs/external_api.min.js”
    <Location /external_api.js>
    Require all granted

    ProxyPreserveHost on
    ProxyPass /http-bind http://localhost:5280/http-bind/
    ProxyPassReverse /http-bind http://localhost:5280/http-bind/

    RewriteEngine on
    RewriteRule ^/([a-zA-Z0-9]+)$ /index.html

That’s it. Reboot server or restart appropriate services and you are good to go on the hostname you have selected.

  • i prefered to move virtualmin to 9999 port because jitsi seems to use 10000->20000 (yes, not tcp but…)

  • i checked “add dns entry” in the subdomain creation

  • i still dont know if java8 is important for (and from) JVB2 update. My config seems to work fine without any error with java11 (mean in env path)

  • It was JVB1 and what i understood was that Jitsi create the virtualhost.conf and not able to modify an existing one, so creating an alias was the solution , then convert it in subserver with all option box needed

  • im not DevOp

Hello,

Inused this Guide to install Jitsi on my server with Virtualmin.

I can access https://meet.dasnetzundich.de and auth.meet.dasnetzundich.de (thats an alias of meet)

But i got only an blank page. The jvb.log has this entrys:

2021-05-03 19:41:25.401 INFO: [60] HealthChecker.run#171: Performed a successful health check in PT0.000011S. Sticky failure: false
JVB 2021-05-03 19:41:45.401 INFO: [60] HealthChecker.run#171: Performed a successful health check in PT0.00001S. Sticky failure: false
JVB 2021-05-03 19:41:55.401 INFO: [60] HealthChecker.run#171: Performed a successful health check in PT0.000007S. Sticky failure: false

Jicofo.log

My contribution: these links worked for me;

Debian 10, Apache2 or nginx web server jitsi-meet installed using;

Ubuntu/Debian Installation Instructions & Repository
Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook
jitsi-meet/jitsi-meet.example-apache at master · jitsi/jitsi-meet · GitHub
https://doc.owncloud.com/server/admin_manual/installation/letsencrypt/apache.html/