Help Error jibri


#21

Hello @bbaldino,

I believe that the data that you request is these

Jitsi-meet: 3081
56%20PM

Jibri: /var/cache/apt/archives/jibri_6.0.59-1_all.deb
51%20PM

Jicofo /var/cache/apt/archives/jicofo_1.0-440-1_amd64.deb
54%20PM

Thanks


#22

This Jicofo version is too old, I’m afraid it looks like we haven’t done a stable release of Jicofo since these protocol changes (this is because we’ve been a bit busy transitioning build infrastructure due to the acquisition).

You can either use the previous stable version of Jibri (jibri_5.1.58-1) or use the unstable version of Jicofo. We’ll be doing a new stable release soon (in the next week or so) so then you can use all latest stable and things will work.


#23

Thank you very much for your response, I will wait for the other week and try the new version that tells me, meanwhile I ask, to install the previous version (jibri_5.1.58-1) as the procedure would be, I ask you , because in the documentation I only see these commands:

  • First install the Jitsi repository key onto your system:

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -

  • Create a sources.list.d file with the repository:

sudo sh -c “echo ‘deb https://download.jitsi.org stable/’ > /etc/apt/sources.list.d/jitsi-stable.list”

  • Update your package list:

sudo apt-get -y update

  • Install the full suite:

sudo apt-get -y install jitsi-meet

or only the packages you need like for example:

sudo apt-get -y install jitsi-videobridge sudo apt-get -y install jicofo sudo apt-get -y install jigasi

Could you please tell me which command I use to install jibri_5.1.58-1 version please


#24

@damencho or @Aaron_van_Meerten can probably be more help with that


#25

There are two approaches here:

wget https://download.jitsi.org/unstable/jibri_5.1.58-1_all.deb
sudo dpkg -i jibri_5.1.58-1_all.deb

or
apt-get install jibri=5.1.58


#26

Hello @damencho and @bbaldino

Good morning, a new machine was deployed to install the recommended JIBRI version, however, the following errors appear when executing the command:

wget https://download.jitsi.org/unstable/jibri_5.1.58-1_all.deb
sudo dpkg -i jibri_5.1.58-1_all.deb

Image 1

I understand that it is a problem of dependencies, however I can not locate where or how to install them, could you tell me how to do it please.


#27

@damencho and @bbaldino

Team good afternoon, after much struggle, I found the cause of my error, to solve it I had to perform the following steps, before installing the Google Chrome driver:

apt-get install libasound2 alsa-utils alsa-oss

JAVA

apt install default-jre
apt install openjdk-11-jre-headless
apt install openjdk-8-jre-headless

FFMPEG

sudo add-apt-repository ppa: mc3man / trusty-media
sudo apt-get update
sudo apt-get install ffmpeg

FFMPEG DEPENDENCIES

sudo apt-get install default-jre-headless ffmpeg curl alsa-utils icewm xdotool xserver-xorg-input-void xserver-xorg-video-dummy

Fortunately, JIBRI now works and is already recording, however at the end of the recording I have the following problems:

  1. The recording only shows video, the audio does not work, how can I solve this?

  2. The recording only shows one camera, that is, for example, if I am the moderator, one time I only record my camera, however in another test, I recorded only one participant, how can I make it so that I only record the moderator’s camera?

  3. There is a way to always leave a user as moderator, for example if I have a conference, but the moderator is late the system leaves as moderator to another, what I really need, is that always a particular user is the moderator , it’s possible?

  4. Is it possible that the recording option is executed automatically at the beginning of the conference, that is, is it possible that the recording system has an “autorecording”?

Thank you very much, I am waiting for the comments.


#28

Hi @gogekkos,

Even I am facing the same issues as you on the Jibri Recording. The recording works fine and the file is created, however, no audio is heard in the recorded file. Please share the solution for this @damencho and @bbaldino.

Jibri logs:

2018-12-06 12:05:50.958 INFO: [26] org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq() Received JibriIq <iq to='jibri@auth.10.115.2.167/eb92899a-1cf6-4233-a0a8-8cf577cbe070' from='jibribrewery@internal.auth.10.115.2.167/focus' id='amlicmlAYXV0aC4xMC4xMTUuMi4xNjcvZWI5Mjg5OWEtMWNmNi00MjMzLWEwYTgtOGNmNTc3Y2JlMDcwADdzT3JuLTUyMTg0AC2yBidqA0ybdyu81St2U4A=' type='set'><jibri xmlns='http://jitsi.org/protocol/jibri' action='start' recording_mode='file' room='jibri@conference.10.115.2.167' session_id='wodykabrnbqejmry'/></iq> from environment prod environment
2018-12-06 12:05:50.961 INFO: [26] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Received start request
2018-12-06 12:05:50.971 INFO: [26] org.jitsi.jibri.api.xmpp.XmppApi.handleStartJibriIq() Sending 'pending' response to start IQ
2018-12-06 12:05:50.972 INFO: [40] org.jitsi.jibri.api.xmpp.XmppApi.run() Starting service
2018-12-06 12:05:50.984 INFO: [40] org.jitsi.jibri.api.xmpp.XmppApi.handleStartService() Parsed call url info: CallUrlInfo(baseUrl=https://10.115.2.167, callName=jibri, urlParams=[])
2018-12-06 12:05:50.991 INFO: [40] org.jitsi.jibri.JibriManager.startFileRecording() Starting a file recording with params: FileRecordingRequestParams(callParams=CallParams(callUrlInfo=CallUrlInfo(baseUrl=https://10.115.2.167, callName=jibri, urlParams=[])), sessionId=wodykabrnbqejmry, callLoginParams=XmppCredentials(domain=recorder.10.115.2.167, username=recorder, password=jibri)) finalize script path: /path/to/finalize_recording.sh and recordings directory: /tmp/recordings
2018-12-06 12:05:59.882 INFO: [40] org.openqa.selenium.remote.ProtocolHandshake.createSession() Detected dialect: OSS
2018-12-06 12:05:59.916 FINE: [40] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.<init>() Detected os as OS: LINUX
2018-12-06 12:05:59.924 INFO: [40] org.jitsi.jibri.service.impl.FileRecordingJibriService.<init>() Writing recording to /tmp/recordings/wodykabrnbqejmry
2018-12-06 12:05:59.957 FINE: [40] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: start:recording
2018-12-06 12:05:59.960 INFO: [40] org.jitsi.jibri.api.xmpp.XmppApi.invoke() Jibri reports its status is now busy, publishing presence to connection prod environment
2018-12-06 12:06:02.441 FINE: [40] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Visiting url https://10.115.2.167/jibri#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME="Jibri"
2018-12-06 12:06:04.851 INFO: [40] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Waited 21 milliseconds for call page to load
2018-12-06 12:06:04.963 INFO: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.launchFfmpeg() Starting ffmpeg with command [ffmpeg, -y, -v, info, -f, x11grab, -draw_mouse, 0, -r, 30, -s, 1280x720, -thread_queue_size, 4096, -i, :0.0+0,0, -f, alsa, -thread_queue_size, 4096, -i, hw:0,1,0, -acodec, aac, -strict, -2, -ar, 44100, -c:v, libx264, -preset, veryfast, -profile:v, main, -level, 3.1, -pix_fmt, yuv420p, -r, 30, -crf, 25, -g, 60, -tune, zerolatency, -f, mp4, /tmp/recordings/wodykabrnbqejmry/jibri_2018-12-06-12-05-59.mp4]
2018-12-06 12:06:05.033 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg is running but doesn't appear to be encoding: 
2018-12-06 12:06:06.036 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg is running but doesn't appear to be encoding: 
2018-12-06 12:06:07.040 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg is running but doesn't appear to be encoding: 
2018-12-06 12:06:08.042 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg is running but doesn't appear to be encoding: 
2018-12-06 12:06:09.049 SEVERE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg is running but doesn't appear to be encoding: [libx264 @ 0x55c9baaa38c0] 264 - core 152 r2854 e9a5903 - H.264/MPEG-4 AVC codec - Copyleft 2003-2017 - http://www.videolan.org/x264.html - options: cabac=1 ref=1 deblock=1:0:0 analyse=0x1:0x111 me=hex subme=2 psy=1 psy_rd=1.00:0.00 mixed_ref=0 me_range=16 chroma_me=1 trellis=0 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=0 threads=1 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=1 keyint=60 keyint_min=6 scenecut=40 intra_refresh=0 rc=crf mbtree=0 crf=25.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
2018-12-06 12:06:10.054 FINE: [40] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.isFfmpegHealthy() Ffmpeg appears healthy: frame=   22 fps= 22 q=26.0 size=       0kB time=00:00:00.70 bitrate=   0.5kbits/s speed=0.693x    
2018-12-06 12:06:10.142 INFO: [40] org.jitsi.jibri.api.xmpp.XmppApi.run() Sending start service response iq: <iq to='jibribrewery@internal.auth.10.115.2.167/focus' id='Sn3mz-34' type='set'><jibri xmlns='http://jitsi.org/protocol/jibri' status='on'/></iq>
2018-12-06 12:06:35.997 INFO: [26] org.jitsi.jibri.api.xmpp.XmppApi.handleJibriIq() Received JibriIq <iq to='jibri@auth.10.115.2.167/eb92899a-1cf6-4233-a0a8-8cf577cbe070' from='jibribrewery@internal.auth.10.115.2.167/focus' id='amlicmlAYXV0aC4xMC4xMTUuMi4xNjcvZWI5Mjg5OWEtMWNmNi00MjMzLWEwYTgtOGNmNTc3Y2JlMDcwADdzT3JuLTUyMjgxAC2yBidqA0ybdyu81St2U4A=' type='set'><jibri xmlns='http://jitsi.org/protocol/jibri' action='stop'/></iq> from environment prod environment
2018-12-06 12:06:35.999 FINE: [26] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: stop:recording
2018-12-06 12:06:36.003 INFO: [26] org.jitsi.jibri.JibriManager.stopService() Stopping the current service
2018-12-06 12:06:36.005 INFO: [26] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Stopping capturer
2018-12-06 12:06:36.007 INFO: [26] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.stopFfmpeg() Stopping ffmpeg process
2018-12-06 12:06:36.413 INFO: [26] org.jitsi.jibri.capture.ffmpeg.executor.FfmpegExecutor.stopFfmpeg() Ffmpeg exited with value 255
2018-12-06 12:06:36.414 INFO: [26] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Quitting selenium
2018-12-06 12:06:36.425 INFO: [26] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Participants in this recording: []
2018-12-06 12:06:36.709 INFO: [26] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 16 log entries for type browser
2018-12-06 12:06:37.103 INFO: [26] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 605 log entries for type driver
2018-12-06 12:06:37.463 INFO: [26] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 0 log entries for type client
2018-12-06 12:06:37.482 INFO: [26] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Leaving web call
2018-12-06 12:06:37.713 INFO: [26] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Quitting chrome driver
2018-12-06 12:06:37.838 INFO: [26] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Chrome driver quit
2018-12-06 12:06:37.844 INFO: [26] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Finalizing the recording

The versions:
Jibri: jibri_5.1.58-1_all.deb
ffmpeg: 3.4.4

Regards,
Abhijit


#29

Hello @abhijitnathwani,

In fact we have the same problem, I have looked at thousands of forums trying to find the solution but it has not been possible, I found in a site, which could be because a file needs to be created in:

etc / jitsi / jibri / asoundrc

The content of this file must be:

playback PCM device: using loopback subdevice 0,0

pcm.amix {
type dmix
ipc_key 219345
slave.pcm “hw: Loopback, 0,0”
}

capture PCM device: using loopback subdevice 0.1

pcm.asnoop {
type dsnoop
ipc_key 219346
slave.pcm “hw: Loopback, 0.1”
}

duplex device combining our PCM devices defined above

pcm.aduplex {
type asym
playback.pcm “amix”
capture.pcm “asnoop”
}

------------------------------------------------- -----

for jack alsa_in and alsa_out: looped-back signal at other ends

pcm.ploop {
type plug
slave.pcm “hw: Loopback, 1,1”
}

pcm.cloop {
type dsnoop
ipc_key 219348
slave.pcm “hw: Loopback, 1.0”
}

------------------------------------------------- -----

default device

pcm.! default {
type plug
slave.pcm “aduplex”
}

However, I did it and it did not work.

I found that another possible error is because the machine (server) does not have a sound card, I do not know if this is real, this I could combine with the command:

arecord -L

aplay -l

However, I still can not find the solution to the audio problem, you do not know if the following:

  1. The recording only shows one camera, that is, for example, if I am the moderator, one time I only record my camera, however in another test, I recorded only one participant, how can I make it so that I only record the moderator’s camera?
  2. There is a way to always leave a user as moderator, for example if I have a conference, but the moderator is late the system leaves as moderator to another, what I really need, is that always a particular user is the moderator , it’s possible?
  3. Is it possible that the recording option is executed automatically at the beginning of the conference, that is, is it possible that the recording system has an “ autorecording ”?

I remain attentive to your comments, happy day.

I hope that @bbaldino and @damencho can help us


#30

Hi @gogekkos,

As per @bbaldino 's reply to one of the other posts, “.asoundrc” must be in the home directory of the jibri user (/home/jibri/.asoundrc) and not /etc/jitsi/jibri , which in my case is present. I had also come across this on one of the github issues, though i’m not able to find the link for that now.

For this, I even tried running jibri on desktop with sound card, but the same issue I was facing.

The audio issue on Jibri is one of the most common. Can @bbaldino and @damencho help with a perfect combination of Jitsi, Jibri, and ffmpeg versions so that we don’t run into troubles so often?

Thanks,
Abhijit.


#31

Hi @gogekkos,

any update on the issue?


#32

Hi @abhijitnathwani how are you?

Still nothing, I still have the same audio problem, however, I’m working on achieving autorecording, you know how to do it?


#33

Hi @gogekkos,

I’m good. Thanks for asking.

Nope, I have no idea about auto-recording. May be you need to programmaticaly trigger the ‘Start Recording’ button on the start of the conference.

Regards,
Abhijit


#34

Hi @bbaldino,

Can you please help us figure out no audio issue on Jibri recordings? Also, I faced with another issue of short video. The video records, but is of only around 10 secs roughly(no audio though), instead of the whole minute I record with stopwatch on.

Need some help here.

Abhijit


#35

I’m afraid I’m not very familiar with the alsa setup, @Aaron_van_Meerten may be able to help with that. As for the short recordings, it’s possible Jibri is taking a while to join the meeting and that’s why you’re not seeing the entire minute? Do you see it joining late or leaving early?


#36

Hi @bbaldino,

I don’t see any irregularities on the Jibri side when I start the recording. The “preparing to record” takes up some 5-6 secs and then the “recording is on” audio plays.

Jibri logs: https://pastebin.com/0XRMhByA
Jicofo logs: https://pastebin.com/pMHqKNAN

@Aaron_van_Meerten any idea on the audio issue?

Abhijit.


#37

Hi @bbaldino @damencho ,

@Aaron_van_Meerten does not seem to be active on the community. As per the profile, he was last seen Jul 6. Can you please suggest any other way to contact him ?

Abhijit


#38

In your Jibri logs, ffmpeg appears to be running for about a minute, so I’d expect you would get that amount of time (you can see in the ffmpeg output logs its runtime). You’re saying the video file itself is only 5 seconds long? Or the video file is long but there is only content for 5 seconds?

@Aaron_K_van_Meerten has 2 usernames it seems. Maybe this is his active one.