Help - Debian setting up user authentication for Jitsi Meet

Help - Debian setting up user authentication for Jitsi Meet

Hello all,
I installed my Jitsi server following these instructions.

I now need to set this up for a school so that only users can use this service.

Setting up the user authentication for Jitsi Meet

But under Debian 11 I can’t find this entry.
nano /etc/jitsi/jicofo/sip-communicator.properties
and can’t find it by find -f either.

How can I set this up in Debian?

You can find the most up-to-date information here

1 Like

Hello and thanks for the link.
Unfortunately I still have problems.

Where should I put the
org.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com
in?

I already added this to /etc/jitsi/jicofo/jicofo.conf - but it didn’t work.

No need to add this line on the new installation. Skip this step.

you replaced jitsi-meet.example.com with your url right ?

You replaced jitsi-meet.example.com with your URL, right?
Yes I did that.

My /etc/jitsi/jicofo/jicofo.conf
looks like this:

Jicofo HOCON configuration. See /usr/share/jicofo/jicofo.jar/reference.conf for

#available options, syntax, and default values.
jicofo {
xmpp: {
client: {
client-proxy: focus.name.dyndns.org
}
trusted-domains: [ “recorder.name.dyndns.org” ]
}
bridge: {
brewery-jid: “JvbBrewery@internal.auth.name.dyndns.org
}
}

jicofo {
  authentication: {
    enabled: true
    type: XMPP
    login-url: name.dyndns.org
 }

name.dyndns.org I have replaced with my address.

problem is that you have 2 jicofo sections, the second one not propertly terminated.
You need to insert

  authentication: {
    enabled: true
    type: XMPP
    login-url: name.dyndns.org
 }

in the previous block, for example just before the last }