HEALTH_CHECK_INTERVAL=-1 ignored by jicofo

Hello, i deployed my own jitsi meet server, on a vmware vps, Debian 8, 4 cpu, 8Gb ram.
I disabled Health Check from jicofo by adding this to /etc/jitsi/jicofo/sip-communicator.properties
org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1, and restarting the system
This setting is ignored by jicofo, as you can see by his log:

Jicofo 2020-06-07 23:57:09.794 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.tps.assistenzapcmc.com
Jicofo 2020-06-07 23:57:09.794 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1
Jicofo 2020-06-07 23:57:09.794 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.auth.URL=XMPP:tps.assistenzapcmc.com
Jicofo 2020-06-07 23:57:09.795 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
Jicofo 2020-06-07 23:57:09.795 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.tps.assistenzapcmc.com
Jicofo 2020-06-07 23:57:09.800 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log() Component org.jitsi.jicofo. config:
Jicofo 2020-06-07 23:57:09.800 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log() ping interval: 10000 ms
Jicofo 2020-06-07 23:57:09.801 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log() ping timeout: 5000 ms
Jicofo 2020-06-07 23:57:09.801 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log() ping threshold: 3
Jicofo 2020-06-07 23:57:09.816 INFO: [11] org.jitsi.jicofo.health.Health.log() Started with interval=10000, timeout=PT30S, maxDuration=PT3S, stickyFailures=false.
Jicofo 2020-06-07 23:57:13.485 INFO: [29] org.jitsi.jicofo.xmpp.BaseBrewery.processInstanceStatusChanged().329 Added brewery instance: jvbbrewery@internal.auth.tps.assistenzapcmc.com/0958797a-7366-47e9-bb23-be11c5360171
Jicofo 2020-06-07 23:57:13.486 WARNING: [29] org.jitsi.jicofo.bridge.BridgeSelector.log() No pub-sub node mapped for jvbbrewery@internal.auth.tps.assistenzapcmc.com/0958797a-7366-47e9-bb23-be11c5360171
Jicofo 2020-06-07 23:57:13.487 INFO: [29] org.jitsi.jicofo.bridge.Bridge.log() Setting max total packet rate of 50800.0
Jicofo 2020-06-07 23:57:13.487 INFO: [29] org.jitsi.jicofo.bridge.Bridge.log() Setting average participant packet rate of 500
Jicofo 2020-06-07 23:57:13.492 INFO: [29] org.jitsi.jicofo.bridge.BridgeSelector.log() Added new videobridge: Bridge[jid=jvbbrewery@internal.auth.tps.assistenzapcmc.com/0958797a-7366-47e9-bb23-be11c5360171, relayId=null, region=null, stress=0.00]
Jicofo 2020-06-07 23:57:19.871 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.074S. Sticky failure: false
Jicofo 2020-06-07 23:57:21.141 INFO: [29] org.jitsi.jicofo.xmpp.BaseBrewery.processInstanceStatusChanged().329 Added brewery instance: jibribrewery@internal.auth.tps.assistenzapcmc.com/jibri-nickname
Jicofo 2020-06-07 23:57:21.141 INFO: [29] org.jitsi.jicofo.recording.jibri.JibriDetector.onInstanceStatusChanged().137 Received Jibri jibribrewery@internal.auth.tps.assistenzapcmc.com/jibri-nickname status
Jicofo 2020-06-07 23:57:21.145 INFO: [29] org.jitsi.jicofo.recording.jibri.JibriDetector.notifyJibriStatus().175 Jibri: jibribrewery@internal.auth.tps.assistenzapcmc.com/jibri-nickname available: true
Jicofo 2020-06-07 23:57:29.808 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.012S. Sticky failure: false
Jicofo 2020-06-07 23:57:39.541 INFO: [32] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: focus.tps.assistenzapcmc.com, null
Jicofo 2020-06-07 23:57:39.803 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.007S. Sticky failure: false
Jicofo 2020-06-07 23:57:49.804 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.007S. Sticky failure: false
Jicofo 2020-06-07 23:57:59.804 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.008S. Sticky failure: false
Jicofo 2020-06-07 23:58:09.804 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.008S. Sticky failure: false
Jicofo 2020-06-07 23:58:19.804 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.008S. Sticky failure: false
Jicofo 2020-06-07 23:58:29.803 INFO: [38] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.006S. Sticky failure: false

In addition I noticed in Prosody one or two rooms with no partecipants, which name is like this:
org.jitsi.jicofo.health.health-fa821172067b8259

It’s only a strange behavior, because the system is working very well, the only unwanted effect is the filling of the jicofo log with the health check messagges.

works fine here.

Jicofo 2020-06-08 20:17:42.058 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true
Jicofo 2020-06-08 20:17:42.059 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1
Jicofo 2020-06-08 20:17:42.061 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.myurl.mytld
Jicofo 2020-06-08 20:17:42.062 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.auth.URL=XMPP:myurl.mytld
Jicofo 2020-06-08 20:17:42.063 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.ENABLE_H264=false
Jicofo 2020-06-08 20:17:42.064 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.ENABLE_VP9=true
Jicofo 2020-06-08 20:17:42.065 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jicofo.ENABLE_VP8=false
Jicofo 2020-06-08 20:17:42.131 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log() Component org.jitsi.jicofo. config: 
Jicofo 2020-06-08 20:17:42.132 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log()   ping interval: 10000 ms
Jicofo 2020-06-08 20:17:42.133 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log()   ping timeout: 5000 ms
Jicofo 2020-06-08 20:17:42.134 INFO: [1] org.jitsi.xmpp.component.ComponentBase.log()   ping threshold: 3
Jicofo 2020-06-08 20:17:42.439 INFO: [11] org.jitsi.jicofo.health.Health.log() Health checks are disabled.

I think we have two different version of jicofo, my jicofo.jar is dated 01/04/2020 (first of April 2020). I don’t know how to get the exact version of my jicofo.
I tried to set `HEALTH_CHECK_INTERVAL=30000, but the interval is always 10000

since most people use Debian packages, I think you can get it with something like

dpkg -l  jitsi*  jicofo  | grep -v none
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
||/ Name                  Version             Architecture Description
+++-=====================-===================-============-=================================================
ii  jicofo                1.0-601-1           all          JItsi Meet COnference FOcus
ii  jitsi-meet            2.0.4706-1          all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody    1.0.4177-1          all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver 1.0.4177-1          all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web        1.0.4177-1          all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config 1.0.4177-1          all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2    2.1-237-gdcf67117-1 all          WebRTC compatible Selective Forwarding Unit (SFU)

this is unstable version (the last available for now)

Ok, many thank for your hint.
My jitsi components versions are the following:


I explored another installation where the jicofo version is 1.0-541-1, where HEALTH_CHECK_INTERVAL is correctly handled.
Perhaps is a bug of the version 1.0-549-1, i will try an update of jitsi-meet to the latest stable version.

Problem solved with the upgrade to the latest stable version

Not here. This setting does not work on my installation, neither with the latest stable nor with the latest ‘unstable’ branches. I keep seeing the HealthChecker events.

2020-09-23 15:20:51.695 INFO: [26] HealthChecker.run#169: Performed a successful health check in PT0.022004S. Sticky failure: false
2020-09-23 15:21:01.575 INFO: [23] VideobridgeExpireThread.expire#140: Running expire()
2020-09-23 15:21:01.674 INFO: [26] Videobridge.createConference#260: create_conf, id=7642bab62cdb0980 gid=-1 logging=false
2020-09-23 15:21:01.683 INFO: [26] HealthChecker.run#169: Performed a successful health check in PT0.00954S. Sticky failure: false
2020-09-23 15:21:11.673 INFO: [26] Videobridge.createConference#260: create_conf, id=4c275b2eeccef61a gid=-1 logging=false
2020-09-23 15:21:11.685 INFO: [26] HealthChecker.run#169: Performed a successful health check in PT0.012379S. Sticky failure: false
2020-09-23 15:21:21.673 INFO: [26] Videobridge.createConference#260: create_conf, id=7f49b247c2cc5f44 gid=-1 logging=false
2020-09-23 15:21:21.708 INFO: [26] HealthChecker.run#169: Performed a successful health check in PT0.034988S. Sticky failure: false
2020-09-23 15:21:31.673 INFO: [26] Videobridge.createConference#260: create_conf, id=6974107af1cefe95 gid=-1 logging=false

/etc/jitsi/jicofo/sip-communicator.properties: (domain names censored)

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.meet..*
org.jitsi.jicofo.auth.URL=XMPP:meet..
org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1

I also added the following line to the end of /etc/jitsi/jicofo/logging.properties

org.jitsi.jicofo.health.Health.level=WARNING

But it seems to have no effect in the logging from what you see.

Try setting org.jitsi.videobridge.health.INTERVAL=-1 in the /etc/jitsi/videobridge/sip-communicator.properties file.

It looks like using a value of -1 to disable health checks was broken at some point. I think we’ll add an explicit enabled property in the new config files to handle that.

1 Like

org.jitsi.videobridge.health.INTERVAL=-1 does not work. JVB signals errors of this option being out of bounds. But I have been able to set org.jitsi.videobridge.health.INTERVAL=3600000 This seems to delay the health check long enough to not pollute the log file.

huh, setting org.jitsi.videobridge.health.INTERVAL=-1 does disable the health checks - according to logs. However, it has the slight side-effect of disabling the statistics too - jvb does not listen anymore to ports 8080 and 9090. Bafflingly this is not stopping Jitsi to work after enabling websockets - while the doc states that it is necessary to enable a connection to port 9090 - maybe it’s only used to tune the connection ?