Having Trouble Installing Luarocks Via DoganBros Script

I ran this script: https://doganbros.com/index.php/jitsi/jitsi-installation-with-jwt-support-on-ubuntu-18-04-lts/ and I get to the part where it creates the new directory mkdir src && and the directory already exists so the script exits. If I try to pick up from that point forward, I end up with errors. If I try to run each command separately I also end up with error. If I purge everything and reinstall I still get errors, even if I run each command separately from the beginning.

Is there as better way to install Lua and Luarocks?

This is in the interest of getting Lua and JWT installed before running the Jitsi install.

I tried again, and here is where I am getting stuck:

Setting up luarocks (2.4.2+dfsg-1) …
Making manifest for /usr/local/lib/luarocks/rocks-5.2
Warning: This looks like a local rocks tree, but you did not pass --local-tree.

Error: Cannot access repository at /usr/local/lib/luarocks/rocks-5.2
dpkg: error processing package luarocks (–configure):
installed luarocks package post-installation script subprocess returned error exit status 1
Setting up lua-sec:amd64 (0.6-4) …
Processing triggers for man-db (2.8.3-2ubuntu0.1) …
Processing triggers for libc-bin (2.27-3ubuntu1.2) …
Errors were encountered while processing:
luarocks
E: Sub-process /usr/bin/dpkg returned an error code (1)

Do I just need to add “–local-tree” to

Did you run apt-get update first?

I always run apt-get update first. But I will try again.

The single quotes in the script are left and right quotes rather than single quotes. That was the whole problem the whole time. Two days of beating my head against the wall for nothing.

Now I just need to connect the server to my GitHub account so that I can download repositories so I don’t get the following message:

fatal: unable to connect to github.com:
github.com[0: 192.30.255.112]: errno=Connection refused

When I attempt to clone the repository manually I get:

root@mysrvname:/usr/src/lua-cjson-2.1.0.6-1/lua-cjson# git clone https://luarocks.org/luajwtjitsi-1.3-7.rockspec

Cloning into 'luajwtjitsi-1.3-7.rockspec'...
fatal: repository 'https://luarocks.org/luajwtjitsi-1.3-7.rockspec/' not found

Evidentially there is a newer repository.

I have tested GitHiub with my own repository and have no trouble cloning it when I trey the following I get the observed errors.

root@meet:/usr/src/lua-cjson-2.1.0.6-1/lua-cjson# luarocks install luajwtjitsi
Installing https://luarocks.org/luajwtjitsi-1.3-7.rockspec
Cloning into ‘luajwt’…
fatal: unable to connect to github.com:
github.com[0: 192.30.255.112]: errno=Connection refused

Error: Failed cloning git repository.

Has the repository be moved somewhere else??

Port 9418 needs to be open on the server in order to communicate with GitHub.

Once port 9418 was opened everything proceeded to conclusion without warning or error.

Now to learn how to use JWT tokens in Jitsi, since they are installed correctly.

This guide works pretty much as advertised with the caveat that you need to customize it to your own server situation.

However, after everything is installed, video and audio are disabled when opening a Jitsi room. Also when I enter the IP in the address bar of the browser, I get the following message:

Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx.org.
Commercial support is available at nginx.com.

Thank you for using nginx.
What additional steps do I have to complete?

If I enter the domain name, meet.politea.us I get the Jitsi webpage, but video and audio are disabled and there is no interface for enabling them. I also get disconnected after about 30 seconds and have to reconnect.

Famous 30 seconds problem