Having problems with jibri recording installation


#1

Hello guys,

This is my first post in this forum.

While trying to install Jitsi Meet and Jibri on my own server(s) with these video tutorials: (https://jitsi.org/news/new-tutorial-installing-jitsi-meet-on-your-own-linux-server/ and https://www.youtube.com/watch?v=OHHoqKCjJ0E&feature=youtu.be), I ran into problems, which I want to describe below:

All attempts happened on a laptop with 2,60 GHz and 8 GB RAM, with Lubuntu 18.10 (64bit, Desktop Edition).

I want to create one single conference room with only three or four participants, and in the end, I want to record the conference (video and audio) locally on the server (no youtube livestreaming needed, but after all my unsuccessful attempts, I activated it anyway…).

I installed first the stable version of Jitsi Meet (following the instructions in the first video tutorial). All participants in the conference room saw each other with video and audio.
I have no FQDN, and I just want to use it in my internal network, so I provided the internal IP address (192.168.2.113) for the installation routine. That all worked like a charm!

Then I followed the steps in the second video tutorial to implement the recording functionality.

I installed it on the same machine; that didn’t work.
After that, I thought I can install the second server (Jibri) on a virtual machine with virt-manager, which at the beginning really worked.
But the record button was just enabled; but when I clicked it, there was no video file in the specified folder.
I thought it might be a good idea to switch the second server from the virtual machine, to another computer, but no improvement.
Then I installed the unstable version in the first step, but it made things worse. I was able to create a new conference room, but it shows the message “Maximum members limit reached” immediately. And the record button is also gone.
Is it really a basic need, to install the unstable version in the first step, or is the unstable version only needed for jibri on the second server?

Additionally, I tried to include all relevant config and log files into a zip file. I have uploaded it here:


If you are missing anything, just report it to me, and I will try to provide it, too.

Any ideas, what am I doing wrong? Please, can anyone help me with that problem?

Greetings from Southwest Germany


#2

First make sure your jitsi-meet deployment works open 2 and then 3 tabs in chrome and make sure it works. Then try adding jibri.
I see in your prosody logs

Nov 06 21:51:17 modulemanager	error	Error initializing module 'muc' on 'conference.192.168.2.113': /usr/lib/prosody/modules/muc/mod_muc.lua:44: Storage error: no data storage active

Change in your prosody config all the lines storage = "null" to be storage = "none" and restart prosody. For quick recover after prosody restart, make sure you first restart jvb and then jicofo, otherwise you need to wait some time (1-2 minutes) before everything reconnects and jicofo discovers the available jvb instances.

Also looking at your jvb configuration you will not be able to use jvb from internet if its not running on a machine that already has public address, as there is no info for its public address https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration.

This is what I saw, from your config/logs.