Having problem while installing let's encrypt (Challenge Failed error) on ubuntu

I have installed jitsi meet with 0 error. But while installing let’s encrypt I get the following error.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for hind.live
Using the webroot path /usr/share/jitsi-meet for all unmatched domains.
Waiting for verification…
Challenge failed for domain hind.live
http-01 challenge for hind.live
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: hind.live
    Type: dns
    Detail: DNS problem: SERVFAIL looking up A for hind.live - the
    domain’s nameservers may be malfunctioning

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

I have edited the FQDN file in the /etc/hosts manually.
and the ping hind.live was also working nicely.
The A records have been set as follows as Destination IP is my VPS IP:

The error shows that the DNS has not been configured. Is there something else I have been missing?
Kindly look into this matter if possible, any kind of help would be appreciated.
Regards

do you have port 80 open on your router/firewall?

try adding a CAA record

name: hind
with 0 issue wildcard
CA DOmain Name : letsencrypt.org

the matter is not that your computer can address your ‘domain’ by name. It’s that the Let’s encrypt computer can address your ‘domain’ by name. And it can only happen when the DNS system (in the entire world) has been upgraded to include the name you want for your domain.
If you absolutely want to be sure, use a web service such as (for example) https://mxtoolbox.com/DNSLookup.aspx to verify that your domain is DNS ready.

Thank you for replying.
I understand now the problem. As I have also checked here. https://intodns.com/hind.live
I have to set the DNS settings from the server as well through SSH.
Kindly can anyone point me in the right direction how can I do that or where can I find the guide or something.
Regards

setting an internet computer into DNS is not usually set with SSH, you have to deal with a registrar. Find one, pay the fee and you will get a domain. This subject is totally off-topic here.

Yes Thank you for your reply. My problem was solved as I had to add my nameserver with the domain registar. That solved the problem totally.