Have to restart jitsi-videobridge after every reboot


I am hosting a jitsi-instance on my laptop (Ubuntu 18.04) in my local network behind my router (DSL connection 100Mbit/s down, 40Mbit/s up). I know that this might not be the ideal setup but since I just do it to have informal conversations with a couple of colleagues, it is okay.
I spent hours of setting up the NAT but now it works like a charm. BUT… after every reboot of Ubuntu I have to restart the service jitsi-videobridge2 (sudo /etc/init.d/jitsi-videobridge2 restart).

The service starts after reboot (= it is shown as active/running) and I can access the start-page of Jitsi using my subdomain - but no video meetings with people from outside my network (= internet) are possible. After restarting the service it starts working again.

Do you have any ideas? Thanks in advance!

1 Like

I thought that the jitsi-videobridge2 is handled by systemd ?
Maybe you mixed systemd and init.d ?
Check with systemctl if the videobridge is both running and enabled by systemd.

It is systemd but has an init script as well. I tried both and have this problem

I believe both jicofo and jvb should start only after prosody is up and running. Did you check the runlevels? Perhaps try to change the runlevels for jvb and jicofo or make the systemd units depend on prosody using the After= option.

What would the syntax of After be for prosody?

If you have systemd unit files for jicofo and jvb you can probably just add After=prosody.service to their Service section. Note however, that I did not test this myself and this will likely only work if all three services are managed by systemd.

They aren’t, they are still init scripts

I suggest to make sure the services are started only after network connection is enabled, since Jitsi may attempt to establish the external IP via STUN on startup. If this does not fix your issue, please try to elaborate on the exact issues you are facing, your setup (OS, install method) and may be add a few lines of the logfiles that have relevant error messages.