Has anyone figured out how to get screen share above 5 FPS?

I’ve been trying for several days now, but no matter what I do I can’t seem to get screen share FPS above 5. We are trying to use screen share to stream video and 5 FPS creates a super choppy video.

I’ve tried the following with no luck:

  1. Changing desktopSharingFrameRate min and max values in config.js
  2. Changing capScreenshareBitrate to 0 or 1 in config.js
  3. Tried presenter mode and noticed that FPS does go up (to about 30), but the video remains choppy. It appears that the screen share component is still at 5 FPS and the video of the presenter is at a higher FPS
  4. Tried Firefox vs Chrome, neither seems to go above 5 FPS
  5. Tried some other things too which I forget now cause I’ve been at this for too long racking my head against the wall

So, has anyone cracked the code on this problem? How do we get a higher FPS on the screen share?

Thanks in advance!

Hi,
as I understood, the config.js is something like a client-side configuration to inform the jitsi-meet web interface about the limits.

To see if the changes you made are applied to the file that is made available to the public, you can take a look into https://your-server/config.js
In some constalations - like using docker jitsi meet - the config.js will be combined with a custom-config.js to allow you to override the default settings.
So you need to make sure your configuration is not overwritten somewhere later in the public config.js file.

The following config works for me:
config.desktopSharingFrameRate = { min: 5, max: 45 };
config.testing.capScreenshareBitrate = 1;

Last but not least, make sure your internet connection and your server aren’t the bottleneck that limiting the framerate.

Okay, finally figured it out!

Yes, need to make the changes in config.js, but we also had to follow damencho’s directions here Desktop Sharing Frame Rate config override not working on meet.jit.si (fps) - #2 by damencho

Once we made those second set of changes, then it worked!