HAProxy service running but request not reach to jitsi meet

Everyday request through HAProxy stop reaching to jitsi meet server, however HAProxy service is always running.

Once we restart the service it starts working.
Please let us know why this happens and how to resolve
Below is our HAProxy Config

global

log /dev/log local0

log /dev/log local1 notice

chroot /var/lib/haproxy

stats socket /run/haproxy/admin.sock mode 660 level admin expose-fd listeners

stats timeout 30s

user haproxy

group haproxy

daemon # Default SSL material locations

ca-base /etc/ssl/certs

crt-base /etc/ssl/private # Default ciphers to use on SSL-enabled listening sockets.

 
ssl-default-bind-ciphers ECDH+AESGCM:xxxxxxM:ECDH+AES256:DH+xxxxxxxxxxx:x+AES128:DH+AES:RSA+AESGCM:RSA+AES:!aNULL:!MD5:!DSS

ssl-default-bind-options no-sslv3 

frontend http

  bind *:80

  bind *:443 ssl crt /etc/ssl/private/abc.abc.com.pem

  redirect scheme https if !{​​​​​​ ssl_fc }​​​​​​

  mode http

# timeout server 3600s

  default_backend meet backend meet

  timeout connect         1m

  timeout client          1m

  timeout server          5m

  balance roundrobin

  stick-table type string len 256 size 200k expire 120m

  stick on url_param(room) table meet

  option httpchk GET /

  http-check expect status 200

  mode http


 server shard1 xxx.xx.xxx.xx:80 check defaults

log global

mode http

option httplog

option dontlognull

        timeout connect 5000

        timeout client  50000

        timeout server  50000

errorfile 400 /etc/haproxy/errors/400.http

errorfile 403 /etc/haproxy/errors/403.http

errorfile 408 /etc/haproxy/errors/408.http

errorfile 500 /etc/haproxy/errors/500.http

errorfile 502 /etc/haproxy/errors/502.http

errorfile 503 /etc/haproxy/errors/503.http

I think this is a HAProxy issue; you might want to check their forums for assistance.