Guests can't start recording/livestream


#1

Hi!
I’ve been trying to upgrade my jibri instance using the debian packages and the tutorial.
And I can see the recording user, but both recording and livestream options are grayed out saying that i’m a guest, when i’m a moderator.

Have you bumped into this issue?


#2

The only error I can see in the logs is this,

2018-07-14 11:08:34.257 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from internal.auth.jitsi.domain.com: XMPPError: remote-server-not-found - cancel![jibri|690x450]

On previous documentation versions seems like,
internal.auth.jitsi.domain.com was referenced by conference.jitsi.domain.com

So far I only see this,

Would you recommend to start the installation from scratch?


#3

Have you configured tokens in your deployment?
Do you have this property enabled in your config.js enableUserRolesBasedOnToken ?


#4

Oh, no, I mean I have them, but as false

enableUserRolesBasedOnToken: false,

Here the /etc/jitsi/meet/jitsi.domain.com-config.js file:

https://paste.ubuntu.com/p/hBJFt5gBr7/

Was RolesBasedOnToken present with the previous (python+bash) jibri infrastructure?


#5

Could I relay on the info exposed here on this topic,


#6

After re-arranging some old files from legacy jibri and fixing some variable at:
/etc/jitsi/meet/jitsi.domain.com-config.js

recordingType: 'jibri',
//    enableRecording: true,
fileRecordingsEnabled: true,
liveStreamingEnabled: true,

Seems like that was my issue, it is now working.
jitsi-jibri-ok

Thanks for all your time and guidance \o/!