Group Video Call Getting Errors - Getting HeapDumpOnOutOfMemoryError on the nice top command

Hello,

We installed Jitsi on Ubuntu server for a app development with aws m5a.large instance (2 core and 8GB ram,Up to 2,120 **Dedicated EBS Bandwidth (Mbps) and 10 network performance Gbps) Also have 4GB swap.

While doing group video call we are getting bandwith reach error and also the below HeapDumpOnOutOfMemoryError process on the nice top.


top - 13:47:32 up 3:57, 1 user, load average: 0.00, 0.01, 0.05
Tasks: 83 total, 1 running, 82 sleeping, 0 stopped, 0 zombie
%Cpu(s): 0.5 us, 0.2 sy, 0.0 ni, 99.3 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem: 7918884 total, 1555252 used, 6363632 free, 57252 buffers
KiB Swap: 4194300 total, 0 used, 4194300 free. 870188 cached Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
6440 jvb 20 0 5818952 334420 17220 S 1.0 4.2 1:47.29 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64 -Dnet.java.sip.communicator.S+
6067 jicofo 20 0 5741556 130544 14968 S 0.3 1.6 0:12.37 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djava.library.path=/usr/share/jicofo/lib/native/linux-64 -Dnet.java.sip.communicator.SC_HOME_DIR_+
1 root 20 0 33512 2840 1492 S 0.0 0.0 0:02.66 /sbin/init


Let me know how to fix it the multiple video call errors and Please suggest the Bandwidth ?

This is an instruction to the virtual machine that is passed when starting the process. You can see all the params that are passed here:


Do you see out of memory error in the logs?

What is the exact problem that you have?

Hello Damian,

We are developing an application for group chat, and video call,
There is no issue with two user calling. While on group call, its every delay to connect and sometimes getting the bandwidth reached limit.

Could you please suggest me a good server configuration(aws) for 30 real-time users.

my jvb.sh file

if there is a logging config file in lib folder use it (running from source)
if [ -f $logging_config ]; then
LOGGING_CONFIG_PARAM="-Djava.util.logging.config.file=$logging_config"
fi

if [ -f $videobridge_rc ]; then
source $videobridge_rc
fi

if [ -z “$VIDEOBRIDGE_MAX_MEMORY” ]; then VIDEOBRIDGE_MAX_MEMORY=3072m; fi

LD_LIBRARY_PATH=$libs exec java -Xmx$VIDEOBRIDGE_MAX_MEMORY $VIDEOBRIDGE_DEBUG_OPTIONS -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djava.library.path=$libs $LOGGING_CONFIG_PARAM $JAVA_SYS_PROPS -cp $cp mainClass @
~


I couldn’t find any memory error in the logs of

tail /var/log/jitsi/jvb.log
JVB 2019-03-01 14:44:00.654 FINE: [251] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId 1blvs-6724):
JVB 2019-03-01 14:44:00.654 FINE: [251] org.jitsi.videobridge.xmpp.ComponentImpl.processIQRequest() (serving component ‘JitsiVideobridge’) Processing IQ request (packetId 1blvs-6724).
JVB 2019-03-01 14:44:00.654 FINE: [251] org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV:
JVB 2019-03-01 14:44:00.654 INFO: [251] org.jitsi.videobridge.Videobridge.log() CAT=stat create_conf,conf_id=191e67bcd5e92dff conf_name=null,logging=false,conf_count=1,ch_count=0,v_streams=0
JVB 2019-03-01 14:44:00.657 INFO: [251] org.jitsi.impl.neomedia.VideoMediaStreamImpl.log() Creating a BandwidthEstimator for stream org.jitsi.impl.neomedia.VideoMediaStreamImpl@1fea818f
JVB 2019-03-01 14:44:00.660 INFO: [251] org.jitsi.impl.neomedia.VideoMediaStreamImpl.log() Creating a BandwidthEstimator for stream org.jitsi.impl.neomedia.VideoMediaStreamImpl@10dcdfec
JVB 2019-03-01 14:44:00.669 FINE: [251] org.jitsi.videobridge.xmpp.ComponentImpl.log() SENT:
JVB 2019-03-01 14:44:00.669 FINE: [251] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Responding to IQ (packetId 1blvs-6724) with:
JVB 2019-03-01 14:44:02.812 FINE: [26] org.jitsi.videobridge.xmpp.ComponentImpl.processIQ() (serving component ‘JitsiVideobridge’) Processing IQ (packetId 3nc30-2591):
JVB 2019-03-01 14:44:02.812 FINE: [26] org.jitsi.videobridge.xmpp.ComponentImpl.log() RECV:

Not aware of such an error. Are you seeing that someone is having connectivity problems are you sure that this is not the other party network? Have you tried the same scenario on meet.jit.si? We are running our bridges on c5.xlarge and they are running just fine.

That’s what I thought. You are not ‘getting HeapDumpOnOutOfMemoryError’ you are seeing a param passed to the jvm when starting jvb when looking at the proceses.

Hello Damina,

Thanks for your update. We have test with different 4G providers network.

Is any bandwidth reach limit by AWS ?

Let me know how to try to same scenario on meet.jit.si ?
Also anything can do with development side for improving this.

What do you mean?

Just open the conference on https://meet.jit.si and see does it behave the same way as what you are experiencing with your own deployment.

Hello,

On video we are getting the below error, and Do you have any idea about the error.

This means that the bandwidth to your device is not enough to be able to receive the video, that’s why it was turned off. This has nothing to do with the jvb, have you tried that on wifi, do you get the same?

Hello,

Yes while using the wifi we have same issues,
We are using two servers one for api call and other request, the Jitsi on another server.

How to find out the issues from my end, Do you have any particular things to check.