Grey screen after enabling secure domain - fixed

I can’t get Jitsi’s authentication system for creating rooms to work at all. And I see a lot of other people have trouble with it as well. So I am trying using simple nginx basic authentication instead. According to the nginx instructions, I need to put some ‘auth_basic’ directives inside the ‘location’ portion of the configuration. So I looked inside the .conf file for my Jitsi web service and under the ‘server’ listening at port 443 I found several ‘location’ sections.

  • /config.js
  • /external_api.js
  • /http-bind
  • A regex expression
  • @root_path

Which is the one where I need to put the auth_basic settings?

That will not work for mobile for example and I’m not sure that will work at all … Instead use this Secure Domain setup · Jitsi Meet Handbook

I tried that. On connecting, all I got was a dark grey browser window with no place to enter credentials.

that’s usually a symptom of a syntax error in config.js, often a forgotten comma. Install node on some Linux computer, (sudo apt install nodejs), grab the file from under /etc/jitsi/meet on your server, and run

node --check yoururl.yourtld-config.js

it should point you to the line in error.

1 Like

Thank you for the tip about commas. That was exactly my problem. By printing out the instructions and reading it under a proper light I could see where I went wrong.

I ran the command but it didn’t return any error. don’t know what to do