Google Cloud Jitsi its not working on 2 or more participants

Hello everyone, i used google cloud for setup. I installed jitsi from the quick-install docs. it built on subdomain also. I made dns settings and give firewall ports for all allowed.because i tried 80,22,443,4444,4443 allowed but not worked either :frowning: Now its not blocked anything,i assume. when i join into a meeting that i created from browser, and from iphone with jitsi-meet application,Btw phone and pc are in same wi-fi, everything works fine. But if another one tries to join meeting video/sound has gone… I tried pc+phone with different network,2 is working ok again.

What can i do i dont know, i am new on this. any help will be fine for me :slight_smile:

Allow UDP/10000 too

forgot to write sorry, also udp 10000-20000 allowed. There is no rule for anything its open to world all ports :frowning: any advice now on

Did you allow both on the system firewall (for example ufw) and on the cloud firewall?

You can check using netcat (nc). There are some posts which show how to do it.

Seems you don’t know that Jitsi-meet has 2 modes, one for p2p (point to point, that is, with 2 users), where jitsi-meet is only an intermediary between the browsers, and multipoint (with 3 users or more, or with 2 if p2p is disabled by the site admin) where everything goes through the videobridge.
When your 2 users are on the same network, p2p works always, when networks are different, not always.
What this mean is that the videobridge does not work. So it usually is that the port 10000 is blocked, check with:

(server)
sudo systemctl stop jitsi-videobridge2
nc -l 10000 -u
(workstation)
echo "123" | nc -u (your public address) 10000

if you don’t see 123 appear on your console, your provider is blocking port 10000 udp.
If port 10000 works, then usually it’s a NAT issue.

 cat /etc/jitsi/videobridge/sip-communicator.properties 
(...)
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=xx.xx.xx.xx
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=yy.yy.yy.yy

replace xx… and yy… by private and public address of server.

If port 10000 works and you don’t have NAT, I don’t know. Maybe javabridge is down ? Check logs.