Google Calendar sign-in is not working on our personal JITSI server

We had set up a JITSI server on our AWS account on an ECS service with an open-source container image.
There are 5 containers running (web, prosody, jicofo, jibril, jvb). image version: stable-7439

We want to integrate a calendar service in Jitsi; I follow this step. issue (we can not sign in google calender)

  1. change ENABLE_CALENDAR to true in the web container.
  2. change GOOGLE_API_APP_CLIENT_ID to our google API client id.
  3. restart all containers.
  4. so we can show the following changes in config.js

// Calendar service integration.
//
config.enableCalendarIntegration = true;
config.googleApiApplicationClientID = <out_client_id>;
// Invitation service.

  1. now we can see the calendar icon in our hosted server.

  2. But when we click on sign in, nothing happens; we cannot log in to Google.

  3. When we clicked on the Sign with Google button, as shown in the above image, the browser returned a status code of 200.

Help: Can anyone suggest why nothing happens when we click on the “sign with Google” tab?
What steps do we have to follow?

Have you followed this: Web integrations | Jitsi Meet

Yes I have followed this step.

When setting it there is a domain/url the enter is that valid and the domain where your deployment is?

@damencho
Yes, it’s valid domain.
Our domain is hosted on godaddy and our server is deployed on AWS on ECS cluster.

No, what do you have in the dashboard when setting up the Google api id, is it the correct domain?

@damencho
Our main domain is xyz.com and our server is running on jitsi.xyz.com,
There is required to put domain while creating Google api id , so i entered https://jitsi.xyz.com

So according to you what is valid domain?

Does jitsi.xyz.com not valid domain?

That … Hum not sure what is going on.

@damencho
Yes
I read all articles and documents and apply above changes but nothing happen when i click on Google sign.
Does there is need to install additional software in container?

Can you provide any suggestions that I have to follow

No errors in the js console?

I think you need to go through the OAuth consent screen and verify the app. Adding scope jitsi-meet/constants.ts at 9533650594f3188462888c843204ead7b7b1cd19 · jitsi/jitsi-meet · GitHub

In js console there is error like below.
Not a valid origin for the client: https://jitsi.xyz.com has not been registered for client ID <our_client_id>.
Our server is running on : jitsi.xyz.com
then what is valid origin in client id?

I suppose this is the problem: Calendar integration broken · Issue #12082 · jitsi/jitsi-meet · GitHub

@raffaelone @damencho
I am using docker jitsi meet GitHub repo: release stable-7439. As mentioned in repo.

Then what do I have to update?

I was doing configuration change in JITSI MEET by env file…

I’m using the latest deb stable/jitsi-meet_8138 on Ubuntu 22.04.01 and the problem hasn’t been fixed yet.

Having the same proble. have you guys have any progress? i get an error
details:You have created a new client application that uses libraries for user authentication or authorization that will soon be deprecated. New clients must use the new libraries instead; existing clients must also migrate before these
error
“idpiframe_initialization_failed”