Getting error when installing npm in android studio

Hi, am getting an error when I am running the command npm install in android studio terminal.

npm WARN deprecated popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
npm WARN deprecated core-js@1.2.7: core-js@<3.23.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Some versions have web compatibility issues. Please, upgrade your dependencies to the actual version of core-js.
npm WARN tarball tarball data for react-native-webrtc@git+https://git@github.com/react-native-webrtc/react-native-webrtc.git#ed07969a85c159953d3004cfd04d44792b95e8db (sha512-hpYt1DuN0QCBuZOXoqR51AxIU2n0lKcGS2YGsww1wYXBCwVzKi6mhVyDVPNH7bU93UBXXnMCzLI4VJzv70GoYg==) seems to be corrupted. Trying again.
npm WARN tarball tarball data for react-native-webrtc@git+https://git@github.com/react-native-webrtc/react-native-webrtc.git#ed07969a85c159953d3004cfd04d44792b95e8db (sha512-hpYt1DuN0QCBuZOXoqR51AxIU2n0lKcGS2YGsww1wYXBCwVzKi6mhVyDVPNH7bU93UBXXnMCzLI4VJzv70GoYg==) seems to be corrupted. Trying again.
npm ERR! code EINTEGRITY
npm ERR! sha512-hpYt1DuN0QCBuZOXoqR51AxIU2n0lKcGS2YGsww1wYXBCwVzKi6mhVyDVPNH7bU93UBXXnMCzLI4VJzv70GoYg== integrity checksum failed when using sha512: wanted sha512-hpYt1DuN0QCBuZOXoqR51AxIU2n0lKcGS2YGsww1wYXBCwVzKi6mhVyDVPNH7bU93UBXXnMCzLI4VJzv70GoYg== but got sha512-Pa3s6fklGxl8tsZQo+AHofIrKVocfQFLor+wCQN8tWnGPqIBMQ/BdXEBtnuBi8hJomqm+3qlJdnjr+0leWNyfA==. (15602238 bytes)

I tried:
npm cache verify and npm clean also deleted and install again but getting stuck here. Please help me to resolve this issue.

which node and npm do you use?

npm: ‘8.5.1’,
node: ‘12.22.9’

Try installing the versions

Node.js >= 16 and npm >= 8 are required.

Delete node-modules folder and try again.

Hi, yes after updating nodejs my problem is solved. in Linux LTS the official version is 12.x. You have to install it manually.

Step1.
First, uninstall the previous version of node and npm.

Step2.
cd ~
curl -sL https://deb.nodesource.com/setup_18.x | sudo bash -

Step3.
sudo apt -y install nodejs

Thank you @damencho