Get the list of rooms


#21

the server is listening on port 5280 and the port is forwarded


#22

I think you have to enable the module for localhost in /etc/prosody/conf.d/localhost.cfg.lua
and replace the line (in nginx)

with
proxy_pass http://localhost:5280/get-info-rooms;


#23

that didn’t work :frowning: and I think proxy_pass is a web server parameter. Isn’t it?


#24

Yes it is.

What is the content of your file /etc/prosody/conf.d/localhost.cfg.lua ?


#25

Only this in that file

-- Section for localhost

-- This allows clients to connect to localhost. No harm in it.
VirtualHost "localhost"

#26

it should be like this

-- Section for localhost
-- This allows clients to connect to localhost. No harm in it.
VirtualHost "localhost"
        -- enabled = false -- Remove this line to enable this host
	app_id=""
	app_secret=""
        authentication = "anonymous"
        modules_enabled = {
            "muc_size";
        }