Generating no pin code for conference call

Hi,

We have installed latest version of jitsi, Jitsi is registered with pbx but dial in and pin code is not generating. Last time two months ago we did not face this issue.

Kind Regards,

Farooq Afzal

What is the config.js setting for dialInConfCodeUrl, do you see any errors in the network tab in you browser dev console?

dialInConfCodeUrl: ‘https://jitsi-api.jitsi.net/conferenceMapper’,

LocalStatsCollector.js:22 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu

Logger.js:154 2021-05-24T18:52:21.110Z [modules/statistics/AnalyticsAdapter.js] <Object.dispose>: Disposing of analytics adapter.

We have done branding. We have changed front logo and Welcome text on homepage. Also changed Title name and Icon. Please be noted that we have integrated FreePBX with jitsi load balancer.

• Create a file titled jitsi_numbers.json, mirror contents of the file below

{"message":"Phone numbers available.","numbers":{"US":["+1.800.123.1234"],"US Alternate":["+1.888.123.1234"]},"numbersEnabled":true}

• Create another file titled jitsiNumberList.php, mirror contents of the file below

<?php
    header('Content-Type: application/json');
    readfile("./jitsi_numbers.json");
    ?>

• Place both files on the FreePBX server under /var/www/html
I use Filezilla for linux to transfer files via ftp

• Enable CORS in Apache. On the FreePBX server, Run terminal command:

sudo nano /etc/httpd/conf/httpd.conf

• Locate and add an Access-Control-Allow-Origin header
replace “https://meet.domain.com ” with your jitsi meet domain.
Should look like this:

<Directory />
    Header set Access-Control-Allow-Origin "https://meet.domain.com"
    AllowOverride none
    Require all denied
</Directory>

• Restart httpd

service httpd restart

7. Jitsi – Edit config.js

• Provide Jitsi with the locations of our phone list and API to use
• From Terminal:

sudo nano /etc/jitsi/meet/meet.domain.com-config.js

• Add the following lines.
First line, swap out “ voip.domain.com ” with your FreePBX FQDN or IP
Second line is using Jitsi’s API

dialInNumbersUrl: 'https://voip.domain.com/jitsiNumberList.php',
dialInConfCodeUrl: 'https://jitsi-api.jitsi.net/conferenceMapper', 

Hi,

Waiting for Your kind response.

Kind Regards,

Farooq Afzal

When you don’t see the numbers and pin, do you see a request to https://voip.domain.com/jitsiNumberList.php?

https://10.100.0.31/jitsiNumberList.php

{“message”:“Phone numbers available.”,“numbers”:{“US”:["+1.301.327.4906"],“US Alternate”:["+1.301.327.4906"]},“numbersEnabled”:true}

root@videoedge:/home/demarcus# curl https://freepbxtest.newagenetworks.com/jitsiNumberList.php
{“message”:“Phone numbers available.”,“numbers”:{“US”:["+1.301.327.4906"],“US Alternate”:["+1.301.327.4906"]},“numbersEnabled”:true}

demarcus@videoedge:~$ curl https://jitsi-api.jitsi.net/conferenceMapper
{“message”:“No conference or id provided”,“conference”:false,“id”:false}demarcus

You don’t see it in the web, right? Have you checked in the network console in the browser fo you see the request?

number

Yep, you need to figure out why that is failing, clicking on it can give you more details and you need to check your webserver logs …

httpd: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using freepbxtest.newagenetworks.com. Set the ‘ServerName’ directive globally to suppress this message

When we made PBX accessible over the internet, it starts to generate code.