Fresh install of Ubuntu 14.04

I have made a fresh install of Ubuntu 14.04 (I think LTS) on an virtual host.

I’m following instructions https://fatiherikci.com/en/install-jitsi-meet-on-debian-10/
The first 3 steps seem to work OK However the last step fails with:

sudo apt-get -y install jitsi-meet

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-videobridge (= 1126-1) but it is not going to be installed
Depends: jicofo (= 1.0-508-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I’m a noob for both Ubuntu and jitsi, Could some hold my hand in getting jitsi installed?

Thanks Bart

This is because systemd requirement.

What I have installed is the only version of ubuntu my host offers.
Can I update Ubuntu 14.04 to a more suitable version for use of jitsi?

Bart

Use 18.04, 14.04 is not recommended it is 6 year old …