Fresh install no moderator (owner) rights (solved)

HI everybody.
I install fresh Jitsi server on Debian 11 and later on Debia10 but at both examples I got the same problem. Any Jitsi user has not moderator rights, even logged in. User icon has no crown icon and users cannot set meeting password, lobby room, … For install I used quickstart guide: Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet and for secure domain: Secure Domain setup | Jitsi Meet. Only a way which I found is to add muc_allowners module into conference.domain component in prosody cfg.lua config file. But after that all users are owners. Can someone help, how to install Jitsi correctly? Thank you.

If you did not succeed in setting up secure domain, my first idea is that maybe you don’t understand how to manage the configuration system used by Jitsi-meet.
I’d admit that it may not be obvious for non developers. When it’s said to add stuff to configuration files, you have to understand that it’s managed in a hierarchical way with sections arranged with { } brackets.
If you add lines but not at the right place, these will be ignored.
This does not apply to Prosody, an independant software managed according to Prosody rules (no brackets, but it has its own complicated caveats).
In short, it’s a gory mess for non experts.
If you feel concerned by this, post your attempts at setting up the secure domain and they will be corrected by the local experts.

Hi gpatel-fr.
Thanks for flash answer. It is miss understanding. As I wrote, I installed fresh Jitsi, it worked. I configured Secure Domain, it works. User must set his nick and next login by username and password. It works too. Only trouble is, the user is not owner. User icon has no crown and in menu More Options / Security Options there is only password setting section but there is no button for set password. So my question is: Is installation script broken? I made fresh install and only modify Secure Domain configuration, nothing more! I just would like to ask where can I repare it. Thank you.

I can only confirm that latest stable works fine with secure domain. Double checking the handbook instructions, I don’t see an obvious mistake in them. So you have probably done something so peculiar I can’t imagine what it is. Post your config files (replace your domain if you must, but please be consistent about it).

What Prosody version did you install?

So, here are my configuration files which I modified after fresh installation and during Secure Domain configuration:
/etc/jitsi/meet/meetings.domain.com-config.js
/etc/prosody/conf.avail/meetings.domain.com.cfg.lua
/etc/jitsi/jicofo/jicofo.conf

How can I upload the code in? It tells me “As a new user cannot upload attachments” and if I copy/paste it in “new usercan make max two links”. Thanks for advice.

Hi saghul,
At debian11 I downgrade to 0.11 after installation and at debian10 is 0.12! I ttry to downgrade it now. Sorry I did not check at debian10. Thought there is older version. My fault.

Not your fault. Prosody 0.12 took us a bit by surprise and there are some bugs still. Please downgrade to 0.11 and retry.

Hmm, I install package prosody-0.11 at debian10 now. It removed prosody (0.12), but prosody.service is masked and unmask cause remove .service file. I can run it by hand /etc/init.d/prosody but it seems it does not work, because login dialog does not appear after nick enter. Should I downgrade it by other way?

Hi saghul,
I downgrade successfuly prosody to 0.11 version at debian10 and it start to work. So, my big apologize. I predict at debian10 is older version of prosody, but did not check it. Thank you very much for good question to direct me to correct way.
Another question: Is it safe to use debian11 now? At debian10 I saw some nessage that lua is danger. Thank you for your answer and flash support. I wish you good luck with Jitsi :slight_smile:

Hi, I am having the same problem, can you please share the command to downgrade?

Hi, at debian / ubuntu:

  1. backup service file. reinstalation remove it and mask the service. instalation do not create new for 0.11
    cp /lib/systemd/system/prosody.service prosody.service.ori
  2. install 0.11 version, it automatically remove 0.12 version
    apt-get install prosody-0.11
  3. move service back
    mv /lib/systemd/system/prosody.service.ori /lib/systemd/system/prosody.service
  4. systemctl unmask prosody
  5. systemctl enable prosody (it should create link to /etc/systemd/system/prosody.service)
  6. systemctl start prosody
  7. systemctl status prosody
1 Like

Thanks a lot. I have made a modification to the script I used to install and I published it here if anyone would need it.