Frequent disconnects (using 8x8 service)

Frequent disconnects (using 8x8 service).

Hi all - we are new to 8x8 (had previously used open source Jitsi + own servers). Over the last few days we have been experiencing frequent disconnects with the 8x8 service and was curious if anyone else is having the issue? In our case, with 100% of the calls, every participant gets disconnected every few minutes.

2021-12-23T02:14:08.150Z [modules/xmpp/XmppConnection.js] Detected that shard changed from prod-8x8-us-east-1b-s11 to prod-8x8-us-east-1b-s1

There was a similar issue reported here, a while back: Frequent disconnects on Jitsi Meet

Would appreciate any insight into this!

Hey @CU8217 welcome to the forum.

How are you using the service? Are you using lib-jitsi-meet or the iframe API?

Hi! We are using lib-jitsi-meet

Are you passing the option websocketKeepAliveUrl?

And are you passing the room name, like this?

We are - we have in there: websocketKeepAliveUrl: ‘https://8x8.vc/ our jaas app id / _unlock’

You need to pass and the room.

Amazing- thank you for the quick help. Will try it and revert back with what we find! Very much appreciate the swift help.

Without the room parameter that request will hit random shard and will detect it as a problem and will reload.

I think we are still possibly doing this incorrectly. We are passing the room via the serviceURL. It sounds like from your comment above, we also need to pass the room via the websocketKeepAliveUrl.
So in addition to the snippet below we also need:

if (connectionConfig.websocketKeepAliveUrl) {
connectionConfig.websocketKeepAliveUrl += ?room=${roomName};

image

Correct? We might be missing something here since as it just threw out some really random errors (about device type) after we tested.

Out of curiosity, was there a recent change / version update that may have led this to happen? Was working very well a couple of weeks ago without this parameter.

Yes, you need to add the same room value you add to the other URL.

Yes, I suspect there was a change in that region that may have provoked your problem.

That seemed to do the trick. Still throwing some errors that say, “Websocket Keep alive failed for url: https://8x8.vc/…” but is no longer disconnecting everyone. Thank you for the help!

Can you try the url without adding the jaasapp id there. Do you still see the errors?

Hi - sure. Gave that a try (i.e. taking out the jaasapp id) and still get that error: “modules/xmpp/XmppConnection.js] Websocket Keep alive failed for url” but it is no longer disconnecting anyone.